bundler-r8864.diff

Toshi MARUYAMA, 2012-02-13 11:08

Download (12.9 KB)

View differences:

Gemfile
1
source :rubygems
2
source :rubyforge
3
source :gemcutter
4

  
5
gem 'bundler', '~> 1.0.0'
6
gem 'rails', '2.3.14'
7
gem 'rack' , '~> 1.1.1'
8
gem 'i18n', '>= 0.4.2'
9
gem 'rubytree', '0.5.2', :require => 'tree'
10
# gem 'coderay', '~> 0.9.7'
11
gem 'coderay'
12

  
13
# Please uncomment lines for your databases.
14
# Alternatively you may want to add these lines to specific groups below.
15
# gem 'sqlite3-ruby', :require => 'sqlite3'  # for SQLite 3
16
# gem 'mysql'                                #     MySQL
17
# gem 'pg'                                   #     PostgreSQL
18
gem 'pg'
19

  
20
group :development do
21
end
22

  
23
group :production do
24
end
25

  
26
group :test do
27
  gem 'shoulda'
28
  gem 'mocha'
29
  gem 'edavis10-object_daddy', :require => 'object_daddy'
30
end
31

  
32
# Load plugins Gemfiles
33
Dir.glob(File.join(File.dirname(__FILE__), %w(vendor plugins * Gemfile))) do |file|
34
  puts "Loading #{file} ..."
35
  instance_eval File.read(file)
36
end
config/boot.rb
41 41
  class Boot
42 42
    def run
43 43
      load_initializer
44

  
45
      Rails::Initializer.class_eval do
46
        def load_gems
47
          @bundler_loaded ||= Bundler.require :default, Rails.env
48
        end
49
      end
50

  
44 51
      Rails::Initializer.run(:set_load_path)
45 52
    end
46 53
  end
config/environment.rb
54 54
  # It will automatically turn deliveries on
55 55
  config.action_mailer.perform_deliveries = false
56 56

  
57
  config.gem 'coderay', :version => '~>1.0.0'
58
  config.gem 'net-ldap', :version => '~>0.2.2'
59

  
60 57
  # Load any local configuration that is kept out of source control
61 58
  # (e.g. gems, patches).
62 59
  if File.exists?(File.join(File.dirname(__FILE__), 'additional_environment.rb'))
config/preinitializer.rb
1
begin
2
  require "rubygems"
3
  require "bundler"
4
rescue LoadError
5
  raise "Could not load the bundler gem. Install it with `gem install bundler`."
6
end
7

  
8
if Gem::Version.new(Bundler::VERSION) <= Gem::Version.new("0.9.25")
9
  raise RuntimeError, "Your bundler version is too old for Rails 2.3." +
10
   "Run `gem install bundler` to upgrade."
11
end
12

  
13
begin
14
  # Set up load paths for all bundled gems
15
  ENV["BUNDLE_GEMFILE"] = File.expand_path("../../Gemfile", __FILE__)
16
  Bundler.setup
17
rescue Bundler::GemNotFound
18
  raise RuntimeError, "Bundler couldn't find some gems." +
19
    "Did you run `bundle install`?"
20
end
Gemfile
2 2
source :rubyforge
3 3
source :gemcutter
4 4

  
5
gem "ruby-openid"
5 6
gem 'bundler', '~> 1.0.0'
6 7
gem 'rails', '2.3.14'
7 8
gem 'rack' , '~> 1.1.1'
......
10 11
# gem 'coderay', '~> 0.9.7'
11 12
gem 'coderay'
12 13

  
13
# Please uncomment lines for your databases.
14
# Alternatively you may want to add these lines to specific groups below.
15
# gem 'sqlite3-ruby', :require => 'sqlite3'  # for SQLite 3
16
# gem 'mysql'                                #     MySQL
17
# gem 'pg'                                   #     PostgreSQL
18
gem 'pg'
19

  
20 14
group :development do
21 15
end
22 16

  
......
24 18
end
25 19

  
26 20
group :test do
27
  gem 'shoulda'
21
  gem 'shoulda', '~> 2.10.3'
28 22
  gem 'mocha'
29 23
  gem 'edavis10-object_daddy', :require => 'object_daddy'
30 24
end
31 25

  
26

  
27
# Use the commented pure ruby gems, if you have not the needed prerequisites on
28
# board to compile the native ones.  Note, that their use is discouraged, since
29
# their integration is propbably not that well tested and their are slower in
30
# orders of magnitude compared to their native counterparts. You have been
31
# warned.
32
#
33
platforms :mri do
34
  group :mysql do
35
    gem "mysql"
36
    #   gem "ruby-mysql"
37
  end
38

  
39
  group :mysql2 do
40
    gem "mysql2"
41
  end
42

  
43
  group :postgres do
44
    gem "pg", "~> 0.9.0"
45
    #   gem "postgres-pr"
46
  end
47

  
48
  group :sqlite do
49
    gem "sqlite3-ruby", "< 1.3", :require => "sqlite3"
50
    #   please tell me, if you are fond of a pure ruby sqlite3 binding
51
  end
52
end
53

  
54
platforms :jruby do
55
  gem "jruby-openssl"
56

  
57
  group :mysql do
58
    gem "activerecord-jdbcmysql-adapter"
59
  end
60

  
61
  group :postgres do
62
    gem "activerecord-jdbcpostgresql-adapter"
63
  end
64

  
65
  group :sqlite do
66
    gem "activerecord-jdbcsqlite3-adapter"
67
  end
68
end
69

  
32 70
# Load plugins Gemfiles
33 71
Dir.glob(File.join(File.dirname(__FILE__), %w(vendor plugins * Gemfile))) do |file|
34 72
  puts "Loading #{file} ..."
config/boot.rb
42 42
    def run
43 43
      load_initializer
44 44

  
45
      # This block was added for bundler support while following setup
46
      # instructions from http://gembundler.com/rails23.html
45 47
      Rails::Initializer.class_eval do
46 48
        def load_gems
47 49
          @bundler_loaded ||= Bundler.require :default, Rails.env
config/environments/test.rb
23 23

  
24 24
# Skip protect_from_forgery in requests http://m.onkey.org/2007/9/28/csrf-protection-for-your-existing-rails-application
25 25
config.action_controller.allow_forgery_protection  = false
26

  
27
config.gem "shoulda", :version => "~> 2.10.3"
28
config.gem "edavis10-object_daddy", :lib => "object_daddy"
29
config.gem "mocha"
Gemfile
69 69

  
70 70
# Load plugins Gemfiles
71 71
Dir.glob(File.join(File.dirname(__FILE__), %w(vendor plugins * Gemfile))) do |file|
72
  puts "Loading #{file} ..."
72
  puts "Loading #{file} ..." if $DEBUG # `ruby -d` or `bundle -v`
73 73
  instance_eval File.read(file)
74 74
end
Gemfile
67 67
  end
68 68
end
69 69

  
70
# Load a "local" Gemfile
71
gemfile_local = File.join(File.dirname(__FILE__), "Gemfile.local")
72
if File.readable?(gemfile_local)
73
  puts "Loading #{gemfile_local} ..." if $DEBUG
74
  instance_eval(File.read(gemfile_local))
75
end
76

  
70 77
# Load plugins Gemfiles
71 78
Dir.glob(File.join(File.dirname(__FILE__), %w(vendor plugins * Gemfile))) do |file|
72 79
  puts "Loading #{file} ..." if $DEBUG # `ruby -d` or `bundle -v`
Gemfile
37 37
  end
38 38

  
39 39
  group :mysql2 do
40
    gem "mysql2"
40
    gem "mysql2", "~> 0.2.7"
41 41
  end
42 42

  
43 43
  group :postgres do
Gemfile
44 44
    gem "pg", "~> 0.9.0"
45 45
    #   gem "postgres-pr"
46 46
  end
47
end
47 48

  
49
platforms :mri_18 do
48 50
  group :sqlite do
49 51
    gem "sqlite3-ruby", "< 1.3", :require => "sqlite3"
50
    #   please tell me, if you are fond of a pure ruby sqlite3 binding
52
  end
53
end
54

  
55
platforms :mri_19 do
56
  group :sqlite do
57
    gem "sqlite3"
51 58
  end
52 59
end
53 60

  
Gemfile
30 30
# orders of magnitude compared to their native counterparts. You have been
31 31
# warned.
32 32
#
33
platforms :mri do
33
platforms :mri, :mingw do
34 34
  group :mysql do
35 35
    gem "mysql"
36 36
    #   gem "ruby-mysql"
37 37
  end
38 38

  
39
  group :mysql2 do
40
    gem "mysql2", "~> 0.2.7"
41
  end
42

  
43 39
  group :postgres do
44 40
    gem "pg", "~> 0.9.0"
45 41
    #   gem "postgres-pr"
......
53 49
end
54 50

  
55 51
platforms :mri_19 do
52
  ## Add Windows support
53
  ## https://github.com/brianmario/mysql2/issues/8
54
  ## Getting mysql2 gem to work with Ruby on Rails 3.0 and Windows 7 64bit
55
  ## http://paul-wong-jr.blogspot.com/2011/06/getting-mysql2-gem-to-work-with-ruby-on.html
56
  group :mysql2 do
57
    gem "mysql2", "~> 0.2.7"
58
  end
59
end
60

  
61
platforms :mri_19, :mingw do
56 62
  group :sqlite do
57 63
    gem "sqlite3"
58 64
  end
Gemfile
2 2
source :rubyforge
3 3
source :gemcutter
4 4

  
5
gem "ruby-openid"
6 5
gem 'bundler', '~> 1.0.0'
7 6
gem 'rails', '2.3.14'
8 7
gem 'rack' , '~> 1.1.1'
......
23 22
  gem 'edavis10-object_daddy', :require => 'object_daddy'
24 23
end
25 24

  
25
group :openid do
26
  gem "ruby-openid", '~> 2.1.4', :require => 'openid'
27
end
26 28

  
27 29
# Use the commented pure ruby gems, if you have not the needed prerequisites on
28 30
# board to compile the native ones.  Note, that their use is discouraged, since
Gemfile
10 10
# gem 'coderay', '~> 0.9.7'
11 11
gem 'coderay'
12 12

  
13
gem "fastercsv", "~> 1.5.0", :platforms => [:mri_18, :jruby, :mingw_18]
14

  
13 15
group :development do
14 16
end
15 17

  
Gemfile
28 28
  gem "ruby-openid", '~> 2.1.4', :require => 'openid'
29 29
end
30 30

  
31
group :rmagick do
32
  platforms :mri_18 do gem "rmagick", "~> 1.15.17" end
33

  
34
  ## You cannot specify the same gem twice with different version requirements.
35
  ## You specified: rmagick (~> 1.15.17) and rmagick (>= 0)
36
  ## https://github.com/carlhuda/bundler/issues/751
37
  # platforms :mri_19 do gem "rmagick" end
38

  
39
  platforms :jruby do gem "rmagick4j" end
40
end
41

  
31 42
# Use the commented pure ruby gems, if you have not the needed prerequisites on
32 43
# board to compile the native ones.  Note, that their use is discouraged, since
33 44
# their integration is propbably not that well tested and their are slower in
Gemfile
24 24
  gem 'edavis10-object_daddy', :require => 'object_daddy'
25 25
end
26 26

  
27
group :ldap do
28
  gem "net-ldap", '~> 0.2.2'
29
end
30

  
27 31
group :openid do
28 32
  gem "ruby-openid", '~> 2.1.4', :require => 'openid'
29 33
end