Upgrading 0.8 to 0.9

Added by QualiConsult Brazil over 9 years ago

According http://www.redmine.org/wiki/redmine/RedmineUpgrade, just doing svn up, my redmine will be upgraded. It didn't work, because each stable version is localized in a branch directory.

Please, see again the procedures to migrate redmine.

Replies (3)

RE: Upgrading 0.8 to 0.9 - Added by Andre Schoonbee over 9 years ago

I also tried the svn update command but get a message Skipped '.'
I used the Turnkey redmine vmimage. I assume the default root location is /var/www/railapp/

I then downloaded the latest stable release also and extracted that to /var/www/redmine091/. I copied all files as per the update instruction and when again to the root location /var/www/railapp/ to execute "rake config/initializers/session_store.rb"
again this failed with:
"rake aborted
Don't know how to build task 'config/initializers/session_store.rb

Please assist
Thanks

RE: Upgrading 0.8 to 0.9 - Added by Vjacheslav Ryzhov over 9 years ago

Help! Upgrading 0.8.4 to 0.9.2
After

rake config/initializers/session_store.rb
rake db:migrate RAILS_ENV="production"

"The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later."

RE: Upgrading 0.8 to 0.9 - Added by Vjacheslav Ryzhov over 9 years ago

This problem is solved successfully.
Add mongrel_cluster_with_rails_23_fix.rb

(1-3/3)