Rails 2.1

Added by Alin Irimie over 9 years ago

Does Redmine run on Rails 2.1?

Replies (6)

RE: Rails 2.1 - Added by Thomas Lecavelier over 9 years ago

Nobody tested it yet. Feel free to try and report results here.

RE: Rails 2.1 - Added by ChunChang Lo over 9 years ago

Being a curious cat, I tried to upgrade to Rails 2.1 with "gem update rails" command in my development environment.
When the upgrade finished, Redmine didn't start in the first place. Then I tried to start console to see what's wrong, it told me to upgrade boot.rb.

# ./script/console
Loading development environment (Rails 2.1.0)
Your config/boot.rb is outdated: Run "rake rails:update".

After running rake command, everything seemed to work OK.

FYI.

BR/shortie
--
'Life's a box of chocolates, Forrest. You never know what you're gonna get.' -- Forrest Gump (1994)
E-Mail: WWW: http://www.cine.idv.tw
IMs: ICQ# 27-118-251 MSN# Skype# shortie2100 Y!# shortie.2100

RE: Rails 2.1 - Added by Jean-Philippe Lang over 9 years ago

A branch was open for Rails 2.1 compatibility but the current trunk (r1524) is not compatible.
Fixes will be merged in trunk as soon as possible.

RE: Rails 2.1 - Added by Alin Irimie over 9 years ago

I think Rails 2.1 breaks the Engines plugins. We had problems with other projects as well ...

RE: RE: Rails 2.1 - Added by James Adam over 9 years ago

The engines plugin should work with Rails 2.1 - check the development on github (http://github.com/lazyatom/engines), and post any bug reports to the lighthouse (http://engines.lighthouseapp.com).

Cheers,

James

RE: RE: RE: Rails 2.1 - Added by Arun Gupta over 9 years ago

In addition to "rake rails:update", I had to comment out Rails version in config/environment.rb. And then I got the following error:

~/samples/jruby/redmine/redmine-0.7 >ruby script/server
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
  • Starting Mongrel listening at 0.0.0.0:3000
  • Starting Rails with development environment...
    GLoc v1.1 running in development mode. Strings can be modified at runtime.
    Exiting
    /Users/arungupta/samples/jruby/redmine/redmine-0.7/vendor/plugins/rfpdf/init.rb:3:in `evaluate_init_rb': undefined method `register_template_handler' for ActionView::Base:Class (NoMethodError)
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/rails/plugin.rb:95:in `evaluate_init_rb'
    from /Library/Ruby/Gems/1.8/gems/activesupport-2.1.0/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/rails/plugin.rb:91:in `evaluate_init_rb'
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/rails/plugin.rb:44:in `load'
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/rails/plugin/loader.rb:33:in `load_plugins'
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/rails/plugin/loader.rb:32:in `each'
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/rails/plugin/loader.rb:32:in `load_plugins'
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/initializer.rb:283:in `load_plugins'
    ... 30 levels...
    from /Library/Ruby/Gems/1.8/gems/rails-2.1.0/lib/commands/server.rb:39
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
    from script/server:3

What could be missing ?

(1-6/6)