What version do I need to get if the latest version of RubyGems I can use is 0.8.11

Added by Eric Smith over 9 years ago

I'm trying to deploy a redmine instance on a shared host where the newest version of RubyGems is 0.8.11. It appears that this restricts me to rails 1.8.6 or lower (I know 2.0.2 requires RubyGems >= 0.9.4 so I've got to go back before that version).

So the question at hand is:

What revision/tag of Redmine do I need to go back to in order to run with such an old version of RubyGems?

Or what would be better for me is:

Is it possible to rub the latest version of Redmine with an older (1.8.6) version of Rails, and if not, what functionality would be lost?

Replies (2)

RE: What version do I need to get if the latest version of RubyGems I can use is 0.8.11 - Added by Thomas Löber over 9 years ago

I think you mean Ruby version 1.8.6 (not Rails) which works fine with Rails 2.1.

On a system with Rails 2.1 installed you can run rake rails:freeze:gems inside your Redmine directory. Then you can copy the vendor/plugins directory to your shared host.

Btw: Did you try to run gem update --system to update RubyGems to the latest version?

RE: What version do I need to get if the latest version of RubyGems I can use is 0.8.11 - Added by Eric Smith over 9 years ago

Sorry, I should have said Rails 1.2.6 instead of 1.8.6.

The issue is that my current hosting provider only supports up to RubyGems 0.8.11. Since Rails 2.1 requires RubyGems 0.9.4, I need to know which revision is compatible with Rails 1.2.6 and doesn't have any Rails 2.x enhancements that could cause problems.

(1-2/2)