Plugins and new releases of Redmine

Added by George Marengo 5 months ago

First of all, thank you to everyone who helps to develop Redmine. It's a wonderful product, and it's very flexible. My question is about Plugins, which is a great idea, but is there a way or plan so that Plugins will work with later versions of Redmine?

One argument could be that it's up to the Plugin developer to update to make it work with later versions of Redmine, but could the developers of Redmine make it easier? Like maybe an interface for Plugins that doesn't change?

I'm not a programmer, so I don't have any idea of what I'm asking for is even possible, but it's disappointing to want to move to a newer version of Redmine, but I can't because a Plugin I need doesn't work on the later version.