undefined method `env_table' for nil:NilClass (NoMethodError)

Added by karim bernardet over 9 years ago

Hi

I am trying to install redmine (svn trunk) + apache on CentOS 5.4 (passenger is installed) and I have this error :

[redmine@projets redmine-svn]$ public/dispatch.cgi
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010. Use #requirement
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/cgi_process.rb:22:in `__send__': undefined method `env_table' for nil:NilClass (NoMethodError)
from /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/cgi_process.rb:22:in `dispatch_cgi'
from /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/dispatcher.rb:101:in `dispatch_cgi'
from /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/dispatcher.rb:27:in `dispatch'
from public/dispatch.cgi:10

My environment is :

[redmine@projets redmine-svn]$ RAILS_ENV=production script/about
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010. Use #requirement
About your application's environment
Ruby version 1.8.6 (x86_64-linux)
RubyGems version 1.3.6
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Application root /home/redmine/redmine-svn
Environment production
Database adapter mysql
Database schema version 20100313171051

It was fine with webrick. I have the same problem with redmine 0.9.3. I have "googled" a lot but didn't find any solution.

Thanks for any tip

Karim

Replies (4)

RE: undefined method `env_table' for nil:NilClass (NoMethodError) - Added by karim bernardet over 9 years ago

I would like to use passenger
do I have to change things in the public .htaccess ?

RE: undefined method `env_table' for nil:NilClass (NoMethodError) - Added by Felix Schäfer over 9 years ago

You might have to delete the public/.htaccess which IIRC can cause errors in passenger setups. Follow the passenger guides (possibly also provided by your distribution) for the rest of the installation.

(1-4/4)