list of package for ruby on rail 2.0.2

Added by Gerardo Aceituna over 9 years ago

He,

Doing weeks who not updated my copy of redmine and now he see who need ruby on rails 2.0.2 but in the computer where has install not have internet connection.

obtain list to package necessaries for download in other computer that version to repositories going to version 2.1

Thanks for time

Replies (6)

RE: list of package for ruby on rail 2.0.2 - Added by Gerardo Aceituna over 9 years ago

list available:

actionmailer-2.0.2
actionpack-2.0.2
activerecord-2.0.2
activeresource-2.0.2
activesupport-2.0.2
rails-2.0.2
rake-0.8.1

but to execute
rake db:migrate RAILS_ENV="production"
result aborted:

rake aborted!
no such file to load -- openssl

(see full trace by running task with --trace)

RE: list of package for ruby on rail 2.0.2 - Added by Thomas Lecavelier over 9 years ago

Please paste here the result of:

ruby --version

Thank you

RE: list of package for ruby on rail 2.0.2 - Added by Gerardo Aceituna over 9 years ago

ruby -v
ruby 1.8.6 (2007-06-07 patchlevel 36) [i486-linux]

gem -v
1.0.1

gem list --local
  • LOCAL GEMS ***
    actionmailer (2.0.2)
    actionpack (2.0.2)
    activerecord (2.0.2)
    activeresource (2.0.2)
    activesupport (2.0.2)
    rails (2.0.2)
    rake (0.8.1)
    sources (0.0.1)

also gem cleanup

RE: list of package for ruby on rail 2.0.2 - Added by Gerardo Aceituna over 9 years ago

$ sudo rake db:migrate RAILS_ENV="production" --trace
(in /home/theboss/redmine)
  • Invoke db:migrate (first_time)
  • Invoke environment (first_time)
  • Execute environment
    rake aborted!
    no such file to load -- openssl
    /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in `require_frameworks'
    /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:88:in `process'
    /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:in `send'
    /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:in `run'
    /home/theboss/redmine/config/environment.rb:20
    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in `require'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:342:in `new_constants_in'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in `require'
    /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/tasks/misc.rake:3
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:546:in `call'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:546:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:541:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:541:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:508:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in `synchronize'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:518:in `invoke_prerequisites'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in `send'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:515:in `invoke_prerequisites'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:507:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in `synchronize'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:494:in `invoke'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1931:in `invoke_task'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:in `standard_exception_handling'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1903:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1881:in `run'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:in `standard_exception_handling'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1878:in `run'
    /usr/lib/ruby/gems/1.8/gems/rake-0.8.1/bin/rake:31
    /usr/bin/rake:19:in `load'
    /usr/bin/rake:19

RE: list of package for ruby on rail 2.0.2 - Added by Eric Davis over 9 years ago

no such file to load -- openssl

You need to install Ruby's OpenSSL library. It's called libopenssl-ruby1.8 on Debian / Ubuntu.

Eric

RE: list of package for ruby on rail 2.0.2 - Added by Gerardo Aceituna over 9 years ago

Thanks Eric!!

I need to update Ruby's OpenSSL library because I have old version to library.

Again thanks to all

(1-6/6)