trac import.

Added by Greg Morehead almost 11 years ago

I am attempting to import from trac ver 0.11

I get the following error:

rake aborted!
file is encrypted or is not a database

Any ideas?

Thanks,
Greg

Replies (6)

RE: trac import. - Added by Thomas Lecavelier almost 11 years ago

Erm... I think it means that the source database is encrypted, or not valid, hu...
Would it be easier for Ms Irma if you explain what type of trac db you have, and which redmine you have, and what command line you entered? Hum?

RE: trac import. - Added by Greg Morehead almost 11 years ago

Sorry for the lack of info.

- I'm using sqlite as the trac db.
- I checked out the redmine trunk

- The command and response:

C:\RedmineSource\trunk>rake redmine:migrate_from_trac RAILS_ENV="production" 
(in C:/RedmineSource/trunk)
WARNING: a new project will be added to Redmine during this process.
Are you sure you want to continue ? [y/N] y
Trac directory []: c:\VecTrac\
Trac database adapter (sqlite, sqlite3, mysql, postgresql) [sqlite]:
Trac database encoding [UTF-8]:
Target project identifier []: software-import
This project already exists in your Redmine database.
Are you sure you want to append data to this project ? [Y/n] y
rake aborted!
file is encrypted or is not a database
(See full trace by running task with --trace)
C:\RedmineSource\trunk>

RE: trac import. - Added by James Turnbull almost 11 years ago

sqlite or sqlite3? There are two different options here. That error could suggest a problem trying to access an sqlite3 database using sqlite2.

RE: trac import. - Added by Greg Morehead almost 11 years ago

I tried both.

RE: trac import. - Added by Greg Morehead almost 11 years ago

I take that back. I didn't realize exactly how to work with sqlite3.

In RedmineMigrate the following is listed:

You need the sqlite-ruby gem (gem install sqlite-ruby) to access the Trac database.

it would be helpful to change it to:

You need the sqlite-ruby gem to access the Trac database.
- For sqlite: gem install sqlite-ruby
- For sqlite3: gem install sqlite3-ruby

Once I installed sqlite3 with gem the import worked.

RE: trac import. - Added by Barbara Post about 10 years ago

I edited the wiki with your change proposal.

(1-6/6)