Problem with upgrade to 1.0.2

Added by Michalis Miatidis about 7 years ago

Hi, I tried to upgrade to 1.0.2 and the following error message appeared during db migration.

Any ideas how to solve it? thanks in advance!

C:\redmine>rake db:migrate --trace
(in C:/redmine)
  • Invoke db:migrate (first_time)
  • Invoke environment (first_time)
  • Execute environment
    rake aborted!
    No such file or directory - C:/redmine/config/environments/production .rb
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:386:in `read'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:386:in `load_en
    vironment'
    C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/core_ex
    t/kernel/reporting.rb:11:in `silence_warnings'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:379:in `load_en
    vironment'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:137:in `process
    '
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `send'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `run'
    C:/redmine/config/environment.rb:20
    C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original
    _require'
    C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
    C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
    ncies.rb:156:in `require'
    C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
    ncies.rb:521:in `new_constants_in'
    C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
    ncies.rb:156:in `require'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/misc.rake:4
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_cal
    l_chain'
    C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_cal
    l_chain'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequi
    sites'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequi
    sites'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_cal
    l_chain'
    C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_cal
    l_chain'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_excep
    tion_handling'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_excep
    tion_handling'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
    C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
    C:/Ruby187/bin/rake:19:in `load'
    C:/Ruby187/bin/rake:19

Replies (4)

RE: Problem with upgrade to 1.0.2 - Added by Holger Just about 7 years ago

No such file or directory - C:/redmine/config/environments/production .rb

Notice the space before the .rb.

I suspect you have enforced the production environment in config/environment.rb. If so, make sure you have no dangling space inside the string. Else, please tell us exactly what you did to setup your redmine.

RE: Problem with upgrade to 1.0.2 - Added by Michalis Miatidis about 7 years ago

Hi, thanks for the answer. I am aware of this space before dot. Where should I search to fix the error? I have not found so far any file containing this pattern. Is this somewhere in the database?

RE: Problem with upgrade to 1.0.2 - Added by Felix Schäfer about 7 years ago

Either in config/environment.rb or in your RAILS_ENV environment variable.

RE: Problem with upgrade to 1.0.2 - Added by Michalis Miatidis about 7 years ago

Thanx a lot. My upgrade script was setting the RAILS_ENV variable value with a space at the end. I fixed it and now it works like a charm.

(1-4/4)