installation problem - Missing the i18n 0.4.2 gem - but it's installed

Added by Louis S over 8 years ago

this is on a shared host

username >> [project] $ gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.5
  - RUBY VERSION: 1.8.7 (2008-06-20 patchlevel 22) [i686-linux]
  - INSTALLATION DIRECTORY: /home/username/ruby/gems
  - RUBY EXECUTABLE: /usr/bin/ruby
  - EXECUTABLE DIRECTORY: /home/username/ruby/gems/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /home/sawtellc/ruby/gems
     - /usr/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - "gempath" => ["/usr/lib/ruby/gems/1.8"]
     - "gem" => "--remote --gen-rdoc --run-tests" 
     - "gemhome" => "/home/username/ruby/gems" 
     - "rdoc" => "--inline-source --line-numbers" 
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/

username >> [project] $ RAILS_ENV=YOUR_ENVIRONMENT script/about
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`

I have configured my redmine installation untill the need to "generate_session_store".
I've had no experience with Ruby and can only seem to get the error:

Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`

when issuing any commands.

Have I made a rookie mistake somewhere during installation?

I am installing a stable release of 1.1.1

my server has the following

i18n     0.4.2
rack     1.0.1
rails     2.3.5
rake     0.8.7

Louis.

Replies (13)

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Etienne Massip over 8 years ago

That should not be :|

Is the 4 gems list the result of the command gem list ?

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Louis S over 8 years ago

No, the gem list is huge. I put down the 4 as they are mentioned in the Redmine Version compatibility

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Etienne Massip over 8 years ago

Could you try to run script/about with ruby executable full path to be sure that it's the one running your scripts ?

/usr/bin/ruby script/about from your redmine dir.

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Louis S over 8 years ago

I get the same line..

username >> [redmine] $ /usr/bin/ruby script/about
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`
username >> [redmine] $ script/about
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Etienne Massip over 8 years ago

Weird.

Did you aready try to uninstall / install the gem ?

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Louis S over 8 years ago

OK. after some lengthy support from Hostgator, I have progressed through the installation, generated session store, migrated db and loaded the default data...

But navigating to the redmine install show a 503 server error

Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Temporarily Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

I got so close!

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Etienne Massip over 8 years ago

What's your configuration (http & ruby server) ?

Nothing in log (servers log) ?

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Louis S over 8 years ago

I don't think I have my cPanel set up properly becuase my error logs are empty..

I have managed to get Redmine working to some extent though.. I'm not sure what it was that I did, but I can login and all the rest.

The problem now is none of the stylesheets (or scripts) have been processed or loaded.

All I need to do I believe is change the path of the links to the resources, which file do I need to edit for this?

(btw thank you for you time and help Etienne!)

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Ricardo Amores over 8 years ago

How did you manage to resolve the
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`
error?

I'm having the same issue

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Louis S over 8 years ago

I'm afriad I had tech support sort out that issue...

the closest I got to get Redmine running was with this guide
http://stefan-radstrom.se/index.php?option=com_content&view=article&id=60:installation-av-redmine-pa-hostgator&catid=27:general&Itemid=46&lang=en

After restarting the app, I'm back to square one so I'm going to leave it for a bit sigh

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Siddharth Pendharkar over 8 years ago

I am running into the same missing i18n 0.4.2 error on Hostgator.

Even typing the command: rake gives you that message.

I have tried to open a hostgator ticket but as of now i have no idea how to resolve the issue and am completely dependent on the tech support at hostgator to figure out what's going on.

RE: installation problem - Missing the i18n 0.4.2 gem - but it's installed - Added by Ве Fio over 8 years ago

I had this issue because i18n 0.5 was installed. It looks like it needs exactly 0.4.2. Run this (it actually tells you what to do, but I too overlooked it at first!):

gem install -v=0.4.2 i18n

(1-13/13)