SVN and HTTPS problem

Added by Loic Stankovic over 8 years ago

Hi

I have a Redmine 1.1.0 server, on Apache2 with Passenger, running on Ubuntu 10.04 LTS. I installed SVN on the same server accessable only on HTTPS with a self-signed cert. I can browse it in Redmine and it works fine. But when I try to browse another SVN, which is on another server, via HTTPS and a self-signed cert too, it gives me:

500
The entry or revision was not found in the repository.

So I upgraded to Redmine 1.1.2, and this time it gave me a 404 error, but with the same message. It the production.log of both versions, it says
...
No close tag for /lists/list
Line:
Position:
Last 80 unconsumed characters:
Output was:
 <?xml version="1.0"?>
<lists>
<list
   path="https://svn.hefr.ch/ICTI_webteam">

I searched for this error, and I found that I got to modify the subversion_adapter.rb. I did it, but now when I try to access to the repository browser with the external SVN, it seems to take all the RAM and make the system crash.

Can someone help me?

Thanks loics2

Replies (11)

RE: SVN and HTTPS problem - Added by Felix Schäfer over 8 years ago

Have you tried the first hint of the FAQ, i.e. logging in to the server running redmine as the user running redmine and trying to permanently accept the certificate?

Another question: might it be that the svn repository on the "other" server is quite big and thus causes Redmine to crash?

RE: SVN and HTTPS problem - Added by Loic Stankovic over 8 years ago

Thanks for the answer
Yeah I did it, but I just figured out that when I press P to accept the certificate, it doesn't seem to be saved, it still asking me to accept the cert.
I don't think the server is big enough to crash Redmine.

RE: SVN and HTTPS problem - Added by Felix Schäfer over 8 years ago

Stankovic Loic wrote:

Yeah I did it, but I just figured out that when I press P to accept the certificate, it doesn't seem to be saved, it still asking me to accept the cert.

Make sure passenger runs as the user you think it runs (perhaps ps aux | grep -i passenger (or rails) will help), and make sure the user has a home directory set and that it can write to.

RE: SVN and HTTPS problem - Added by Loic Stankovic over 8 years ago

I checked it, but I don't really know as which user it should be run... Apache2 runs as www-data (like I expected) but passenger runs as root.

And apparently, when I launch the svn command with the --non-interactive, the authentication fails, so I think that causes the problem in Redmine.

RE: SVN and HTTPS problem - Added by Felix Schäfer over 8 years ago

Stankovic Loic wrote:

I checked it, but I don't really know as which user it should be run... Apache2 runs as www-data (like I expected) but passenger runs as root.

A few passenger processes run as root, yes, what do the other run as, or even more specifically what user do the redmine processes run as? The processes are called Rails: /path/to/your/redmine. Passenger supports user switching, and might not always run apps as the user you think it does.

RE: SVN and HTTPS problem - Added by Loic Stankovic over 8 years ago

It runs as www-data too (it's part of the sudoers and all the Redmine folder is owned by this user)

RE: SVN and HTTPS problem - Added by Felix Schäfer over 8 years ago

Then www-data probably can't write to its home directory, and thus can't save the preference to permanently accept the certificate.

RE: SVN and HTTPS problem - Added by Loic Stankovic over 8 years ago

Why my messages appear to be spam?!

RE: SVN and HTTPS problem - Added by Loic Stankovic over 8 years ago

The /var/www folder (which is the home folder of www-data I think) was owned by root, so I changed that. Now a can run the svn commande with sudo -u www-data and it returns the expected result.
But the system still crashing when I try to access to the repository browser.

RE: SVN and HTTPS problem - Added by Loic Stankovic about 8 years ago

Everything's working now, there was a lot of authorization problems on folders.
Thanks for your help.

RE: SVN and HTTPS problem - Added by li an almost 5 years ago

Hi, when svn is https, redmine cannot show it normally with 404 error, can you guide the final resolution way? I am using bitnami redmine 2.3.2. thanks.

(1-11/11)