No options in SCM list (Project settings -> Repository tab)

Added by Travis Briggs over 6 years ago

I'm trying to set up SCM with subversion for the first time. I found a how to page (http://www.redmine.org/projects/redmine/wiki/RedmineRepositories) but one of the first steps is:

Select the SCM that corresponds to your repository

However, the list is empty, in that only the " --- Please select --- " option is available.

I am an admin on this redmine installation, with root access to the hosting machine, but I did not participate in setting it up.

Just wondering, is there some obvious, easy step that I'm missing? Or do I need to go through a more rigorous debug of my installation?

Thanks!

No_SCM_options.png - No options in SCM list (12.2 KB)

Replies (3)

RE: No options in SCM list (Project settings -> Repository tab) - Added by Billy T over 6 years ago

Check out if you have enabled any SCM here:
Administration->settings->Repositories->Enabled SCM

RE: No options in SCM list (Project settings -> Repository tab) - Added by Travis Briggs over 6 years ago

Rather than start a new thread, I'm going to keep posting here.

I've enabled Subversion SCM globally. I've linked the repo in the Project Settings -> Repository tab. I can browse the repository from Redmine.

Changeset linking from Issue comments is not working, however.

so r8000 stays as plain text.

Same as before, I'm not sure if there's another checkbox somewhere that I need to simply check off, or if this is an unexpected failure. If the latter, where do I start looking to debug the issue? log/production.log?

Thanks!

(1-3/3)