Error after Upgrade from 1.1.1 to 1.2.1

Added by Sven Schuchmann over 8 years ago

Hi,
I just downloaded the release version 1.2.1 and tried to upgrade my 1.1.1 version to.
On Startup I get the following error:

TheServer:/home/redmine_Bugtracker121 # ruby script/server -e RM_DB -p 2002
=> Booting Mongrel
=> Rails 2.3.11 application starting on http://0.0.0.0:2002
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/mongrel.rb:10:in `initialize': wrong number of arguments (5 for 4) (ArgumentError)
        from /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/mongrel.rb:10:in `new'
        from /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/mongrel.rb:10:in `run'
        from /home/redmine_Bugtracker121/vendor/rails/railties/lib/commands/server.rb:111
        from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3

Version are as follows:

rake --version
rake, version 0.8.7

ruby --version
ruby 1.8.7 (2008-08-11 patchlevel 72) [i586-linux]

gem --version
1.3.5

Can anyone help me?

Replies (1)

RE: Error after Upgrade from 1.1.1 to 1.2.1 - Added by Sven Schuchmann over 8 years ago

Okay, Problem solved :-)

TheServer:/home/redmine_Bugtracker121 # ruby script/server webrick -e RM_DB -p 2002

(1-1/1)