404 not found for all attachments

Added by Michael Diederich about 6 years ago

I have a redmine 1.2.1 install, migrated from trac.
When I access tickets and click on the attachment, I get the link http://redmine.MYSERVER.com/attachments/1472/_4479.xlsx and then a 404 not found

I use apache2 and passenger

apeliotes:/opt/redmine# RAILS_ENV=production script/about
About your application's environment
Ruby version              1.8.7 (i486-linux)
RubyGems version          1.3.7
Rack version              1.1.1
Rails version             2.3.11
Active Record version     2.3.11
Active Resource version   2.3.11
Action Mailer version     2.3.11
Active Support version    2.3.11
Edge Rails revision       unknown
Application root          /opt/redmine
Environment               production
Database adapter          mysql
Database schema version   20110511000000

Can anyone help me? Thanks!

Replies (2)

RE: 404 not found for all attachments - Added by Michael Diederich about 6 years ago

sorry, my gem list:

apeliotes:/opt/redmine# gem list

*** LOCAL GEMS ***

actionmailer (2.3.11)
actionpack (2.3.11)
activerecord (2.3.11)
activeresource (2.3.11)
activesupport (2.3.11)
cgi_multipart_eof_fix (2.5.0)
daemon_controller (0.2.6)
daemons (1.1.4)
fastthread (1.0.7)
gem_plugin (0.2.3)
i18n (0.4.2)
mongrel (1.1.5)
mysql (2.8.1)
passenger (3.0.7)
rack (1.1.1, 1.0.1)
rails (2.3.11)
rake (0.8.7)
rmagick (2.10.0)
sqlite3 (1.3.4)
sqlite3-ruby (1.3.3)

RE: 404 not found for all attachments - Added by Michael Diederich about 6 years ago

I found my error - I had two redmine installations, the files from the trac migration where stored in the wrong one.

(1-2/2)