Getting Errno::ECONNRESET trying to send email after upgrade from 0.6.4 to 0.7.3

Added by YA Chris about 11 years ago

Hello,

Getting an error trying to send email. This is after an upgrade from 0.6.4 to 0.7.3, and everything else works, but email does not.

The installation under 0.6.4 worked fine. I've copied over the changes to environment/development.rb and environment/production.rb.

The error I get is an Errno::ECONNRESET in IssuesController#new -- anyone seen this? Have a clue how to fix it?

Running Ruby 0.8.6 from InstantRails under windows, Rails 2.0.2.

Thanks!

Replies (1)

RE: Getting Errno::ECONNRESET trying to send email after upgrade from 0.6.4 to 0.7.3 - Added by YA Chris about 11 years ago

Figured it out!

Turns out that I was a little too quick to copy lines from config/environment/production.rb and didn't pay VERY careful attention to the installation instructions.

In Redmine 0.6.4, the following works:

# In config/environment/production.rb:
ActionMailer::Base.smtp_settings = {
    :domain => "foo.bar",
# etc.
}

BUT in Redmine 0.7.3 it should be:

# In config/environment/production.rb:
config.action_mailer.smtp_settings = {
    :domain => "foo.bar",
# etc.
}

I believe this is a difference between Rails 1.2.6 (which is in the 'vendor' directory for Redmine 0.6.4) and Rails 2.0.2.

(1-1/1)