Email Configuration /redmine/config/configuration.yml

Added by Julien Marchand about 6 years ago

Hello,

Acutally I've got some troubles with Redmine.

Currently, I've got stable redmine 1.2.1 and I'd like to setup the email notification. I tried some changes on configuration.yml file in the folder config/configuration, but I have the following error message :

"The email dispatching is not setup, notifications are disable. Setup your SMTP server in config/configuration.yml and launch again the software to enable them."

Is anybody having the same trouble or maybe could help me ?

Of course I've already read the email setup documentation at the following address : http://www.redmine.org/projects/redmine/wiki/EmailConfiguration but unfortunatly with no results.

Hope you have answers.

Thanks.

Replies (15)

RE: Email Configuration /redmine/config/configuration.yml - Added by Etienne Massip about 6 years ago

I guess this error is displayed when you try to send a test email?
Did you restart your instance? Could you post your configuration.yml? Is there an old email.yml file remaining?

RE: Email Configuration /redmine/config/configuration.yml - Added by Julien Marchand about 6 years ago

No, this error only happens when I click on the item "Email notification" and I'm still looking for sending a test email.

It's not "email.yml" but "configuration.yml" . Redmine 1.2.1 stable version

production:
email_delivery:
delivery_method: :smtp
smtp_settings:
tls: true
enable_starttls_auto: true
address: xxxx
port: 25
domain: xxx
authentification: none

Sorry for adress and domain but i'm a company ;)

RE: Email Configuration /redmine/config/configuration.yml - Added by Etienne Massip about 6 years ago

email.yml is the old file name, I wanted to check that there were no such file.

Did you restart your instance? Can you please post the file? Do you have something in you production.log file?

RE: Email Configuration /redmine/config/configuration.yml - Added by Julien Marchand about 6 years ago

Yes I rebooted my instance, and I've got nothing in production.log

I don't know where to start to enable email notification.

RE: Email Configuration /redmine/config/configuration.yml - Added by Jon Steiner about 6 years ago

I downloaded redmine 1.2.1.

I'd like to know, to set up email, do I modify configuration.yml? If so, where is it?

I only see /config/email.yml.example. What do I do with it?

Thanks,

blue

RE: Email Configuration /redmine/config/configuration.yml - Added by Jon Steiner about 6 years ago

There is a file called email.yml.example.

However, the page in the Guide suggests I use configuration.yml.

This is a contradiction.

Please suggest a solution.

RE: Email Configuration /redmine/config/configuration.yml - Added by Jon Steiner about 6 years ago

There is a file called email.yml.example in Bitnami Redmine 1.2.1

However, the page in the Guide suggests I use configuration.yml. This doesn't seem to exist in Bitnami Redmine 1.2.1

This is a contradiction.

Please suggest a solution.

RE: Email Configuration /redmine/config/configuration.yml - Added by Etienne Massip about 6 years ago

It's a mistake from Bitnami since email.yml is deprecated in favor of configuration.yml and thus shouldn't be bundled anymore.

RE: Email Configuration /redmine/config/configuration.yml - Added by Jon Steiner about 6 years ago

Thank you, Etienne. I will let them know.

RE: Email Configuration /redmine/config/configuration.yml - Added by JP Stringham over 5 years ago

Apologies for the bump, but I have the same issue as the OP. It appears this issue was never answered but that somehow he sorted it out himself...

I've set up the configuration.yml file by copying the example and setting the production environment to use sendmail, however I continue to get the error that reads:

"Email delivery is not configured, and notifications are disabled.
Configure your SMTP server in config/configuration.yml and restart the application to enable them."

This doesn't make sense since the configuration.yml file is there and I've requested that it uses sendmail. I've restarted apache (and consequently mod_rails) several times. Has anyone else had this issue? Or could the OP clear up how he fixed it?

RE: Email Configuration /redmine/config/configuration.yml - Added by Dima Antonov over 5 years ago

This is my code in configuration.yml to local area:

  1. default configuration options for all environments
    default: # Outgoing emails configuration (see examples above)
    email_delivery:
    delivery_method: :smtp
    smtp_settings:
    address: 192.168.2.2
    port: 25
    domain: domain.com
    authentication: :plain
    user_name: ""
    password: "redmine"

RE: Email Configuration /redmine/config/configuration.yml - Added by Peter Wang over 5 years ago

Hi, Julien,

Did you just remove the comment of the example and add your mail setting?
if yes, I guess it might be caused by the additional "production:" section at the end of the configuration.yml file

Peter
Julien Marchand wrote:

Yes I rebooted my instance, and I've got nothing in production.log

I don't know where to start to enable email notification.

RE: Email Configuration /redmine/config/configuration.yml - Added by Francis Lee Mondia over 5 years ago

In addition to this, take note:

THIS SHOULD BE A VALID YML FILE.

I found this the hard way. Turns out, removing the comments messed this up. I spend two days debugging this and finally I solved it by fixing the spaces on the uncommented lines.

Take note also to remove the production line near the bottom. The previous post gave the hint to check to production: directive near the email configuration line. I had to make it stick to the fist column be removing the space and fixing the spaces afterwards for the email directives (it had 3 spaces from the 1st column). The start of the email directives is two spaces from the previous line's first line.

Just my two cents. Its a great software and I want to help others who are experiencing this problem.

RE: Email Configuration /redmine/config/configuration.yml - Added by jerome l over 4 years ago

That ' s true it was a problème of yaml incorrect syntax.
now i Know That i must respect the Space indentation :)
see you

(1-15/15)