Upgrading from 1.2.2 to 1.3.0

Added by Jean-Michel G over 7 years ago

Hello, I have redmine 1.2.2 on Ubuntu Lucid Lynx 10.04 server, but I can't upgrade it.
I follow http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade but When I try rake db:migrate RAILS_ENV=production I have following error:

$ rake db:migrate RAILS_ENV=production
(in /var/www/redmine)
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0xb713ac9c>

(See full trace by running task with --trace)

$ rake db:migrate RAILS_ENV=production --trace
(in /var/www/redmine)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0xb71879fc>
/var/lib/gems/1.8/gems/rails-2.3.14/lib/rails/gem_dependency.rb:81:in `add_load_paths'

I upgraded rails to 2.3.14 and uninstalled 2.3.11.

Thanks for your help.

Replies (26)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Stéphane Liabat over 7 years ago

I made a new post.

sorry.

1 2 (26-26/26)