Redmine 1.4.0 on JRuby 1.6.7 (Ruby 1.9 Mode)

Added by Daniel Morgan over 5 years ago

I am trying to upgrade Redmine from 1.3.2 to 1.4.0 on a Windows XP box.

All is fine, except I cannot successfully install the net-ldap gem.
The following error occurs when installing under JRuby 1.6.7 (Ruby 1.9 Mode):

ERROR:  While executing gem ... (ArgumentError)
    invalid byte sequence in Windows-31J

I have searched the web for solutions, but no success so far.
The error does not occur under Ruby 1.8 Mode.

Has anybody encountered similar problems?
Any advice would be greatly appreciated.

Replies (2)

RE: Redmine 1.4.0 on JRuby 1.6.7 (Ruby 1.9 Mode) - Added by Terence Mill about 5 years ago

News on that?

Does anyone sucessfully runs redmine 2.x on jruby (torquebox or tomcat)

Please provide installation hints.

RE: Redmine 1.4.0 on JRuby 1.6.7 (Ruby 1.9 Mode) - Added by Daniel Morgan about 5 years ago

I've got Redmine 1.4.x running with TorqueBox.
However, with 2.x, I cannot get Redmine running with config.threadsafe! enabled.
As a result, I'm stuck with 1.4.x.

(1-2/2)