Could not locate Gemfile

Added by Sylvain Hamel over 7 years ago

I am trying to upgrade to 1.4.1 from 1.3.3.

Is there a how to somewhere ?

It seems it is not as simple as doing a svn update .

Having found none (surprisingly) I went from the install instruction after having done a backup.

I tried this :

bundle install --without development test

and got the error message Could not locate Gemfile .

I guess it wants me to run the command in a specific folder but I dont know which one.

Can anybody help me ?

Replies (13)

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

If you are using svn, you must use svn switch to switch 1.4 redmine branch. Or delete version 1.3 and install version 1.4 as new.

RE: Could not locate Gemfile - Added by Grzegorz Tomasiak over 7 years ago

I have the same problem, I have tried to upgrade redmine from 1.0.0 to 1.4.1 and after a command:

bundle install --without development test

I got this error:

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for pg_config... no
No pg_config... trying anyway. If building fails, please try again with
 --with-pg-config=/path/to/pg_config
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

[...]
An error occured while installing pg (0.13.2), and Bundler cannot continue.
Make sure that `gem install pg -v '0.13.2'` succeeds before bundling.

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

bundle install --without development test postgresql

RE: Could not locate Gemfile - Added by Grzegorz Tomasiak over 7 years ago

Finally I go forward... I got nice green message

Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.

but now, when I want to do the following command

rake config/initializers/session_store.rb

I got problem with rake:


rake aborted!
uninitialized constant Rake::DSL
/usr/lib/ruby/1.8/rake.rb:2503:in `const_missing'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/tasklib.rb:8
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/testtask.rb:4:in `require'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/testtask.rb:4
/usr/share/redmine/Rakefile:7:in `require'
/usr/share/redmine/Rakefile:7
/usr/lib/ruby/1.8/rake.rb:2383:in `load'
/usr/lib/ruby/1.8/rake.rb:2383:in `raw_load_rakefile'
/usr/lib/ruby/1.8/rake.rb:2017:in `load_rakefile'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:2016:in `load_rakefile'
/usr/lib/ruby/1.8/rake.rb:2000:in `run'
/usr/lib/ruby/1.8/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/1.8/rake.rb:1998:in `run'
/usr/bin/rake:28

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

Try to use rake version 0.8.7 (remove version 0.9.2.2)

RE: Could not locate Gemfile - Added by Grzegorz Tomasiak over 7 years ago

I tried this, and rake had no problems at all, but I had message that I need to update bundle, so it goes back again to version 0.9.2.2 and did not continue with process.

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

Please print RAILS_ENV=production script/about and gem list here.

RE: Could not locate Gemfile - Added by Grzegorz Tomasiak over 7 years ago

That's a script/about


#!/usr/bin/env ruby
require File.expand_path('../../config/boot',  __FILE__)
$LOAD_PATH.unshift "#{RAILTIES_PATH}/builtin/rails_info" 
require 'commands/about'

Redmine::About.print_plugin_info

and gems list

*** LOCAL GEMS ***

actionmailer (2.3.14, 2.3.5)
actionpack (2.3.14, 2.3.5)
activerecord (2.3.14, 2.3.5)
activeresource (2.3.14, 2.3.5)
activesupport (2.3.14, 2.3.5)
bundler (1.1.3)
coderay (1.0.6)
daemon_controller (0.2.6)
edavis10-object_daddy (0.4.3)
fastercsv (1.5.4)
fastthread (1.0.7)
i18n (0.4.2)
json (1.6.6)
metaclass (0.0.1)
mocha (0.11.1)
mysql (2.8.1)
net-ldap (0.3.1)
passenger (3.0.11)
pg (0.13.2)
rack (1.1.3, 1.0.1)
rails (2.3.14, 2.3.5)
rake (0.9.2.2, 0.8.7)
rmagick (2.13.1)
ruby-openid (2.1.8)
sqlite3 (1.3.6)
tzinfo (0.3.33)

I don't know where to find RAILS_ENV=production :(

RE: Could not locate Gemfile - Added by Sylvain Hamel over 7 years ago

Alex A wrote:

If you are using svn, you must use svn switch to switch 1.4 redmine branch. Or delete version 1.3 and install version 1.4 as new.

Would switching branch to 1.4 leave me with lots of useless files ?

Could someone give the correct command to swith to the current version ?

Database migration is the same as usual ?

Are there any changes to configuration file ?

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

Grzegorz Tomasiak wrote:

I tried this, and rake had no problems at all, but I had message that I need to update bundle, so it goes back again to version 0.9.2.2 and did not continue with process.

you can install gems without bundler, manually.

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

Sylvain Hamel wrote:

Would switching branch to 1.4 leave me with lots of useless files ?

Could someone give the correct command to swith to the current version ?

Database migration is the same as usual ?

Are there any changes to configuration file ?

svn switch <url to new branch>
rake db:migrate RAILS_ENV=production
rake db:migrate_plugins RAILS_ENV=production

Then restart redmine server (apache, mongrel etc.)

RE: Could not locate Gemfile - Added by Alex A over 7 years ago

Grzegorz Tomasiak wrote:

I got problem with rake:

rake aborted!
uninitialized constant Rake::DSL

The problem solved by updating rubygems to version 1.8

RE: Could not locate Gemfile - Added by penkerch christophe over 7 years ago

To make it works,
I had also to add this line in /redmine-1.4.1/Rakefile
require 'rake/dls_definition'
as mention in the post http://www.redmine.org/issues/8588

(1-13/13)