Redmine requires Bundler. But it's there!!

Added by Jérémy Chatard about 7 years ago

I'm upgrading from 1.3.2 to 1.4.1.

During the upgrade process, when running: rake generate_session_store

Redmine complains about Bundler. I then run

gem install bundler
bundle install --without development test rmagick postgresql // as described elsewhere.

The output seems good:

Using rake (0.9.2.2) 
Using activesupport (2.3.14) 
Using rack (1.1.3) 
Using actionpack (2.3.14) 
Using actionmailer (2.3.14) 
Using activerecord (2.3.14) 
Using activeresource (2.3.14) 
Using coderay (1.0.6) 
Using fastercsv (1.5.4) 
Using i18n (0.4.2) 
Using mysql (2.8.1) 
Using net-ldap (0.3.1) 
Using rails (2.3.14) 
Using ruby-openid (2.1.8) 
Using sqlite3 (1.3.6) 
Using tzinfo (0.3.33) 
Using bundler (1.1.3) 
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.

But when re-running rake generate_session_store, Redmine still complains about the following:

Redmine requires Bundler. Please install it with `gem install bundler`.

Is there any cache of something that Redmine use to not check the last config?

I'm using Ruby Enterprise, don't know if this makes any difference.

Thanks,
Jérémy

Replies (34)

RE: Redmine requires Bundler. But it's there!! - Added by Alex A about 7 years ago

Try to add

ENV['GEM_PATH'] = "/usr/local/lib/ruby/gems/1.8:#{ENV['GEM_PATH']}" 

into your config/environment.rb file, where /usr/local/lib/ruby/gems/1.8 your path to the gems.

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

Did anyone find a solution/workaround?

Thanks,
Jérémy

RE: Redmine requires Bundler. But it's there!! - Added by Nestor Diaz about 7 years ago

just for Jeremy, I made a full rvm method install :/

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

Oh! Not really what I wanted to do.

Well so, I think I'll give it a try then.

Thanks Nestor.

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

try specifying the full rake executable path, it seems that you're not running the right one?

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

I'm running it with the full path:

/opt/ruby-enterprise-1.8.7-2011.03/bin/rake generate_session_store

But still getting:

Redmine requires Bundler. Please install it with `gem install bundler`.

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

What about /opt/ruby-enterprise-1.8.7-2011.03/bin/bundle list (in Redmine folder) and @/opt/ruby-enterprise-1.8.7-2011.03/bin/gem env?

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

/opt/ruby-enterprise-1.8.7-2011.03/bin/bundle list

Outputs:
Gems included by the bundle:
  * actionmailer (2.3.14)
  * actionpack (2.3.14)
  * activerecord (2.3.14)
  * activeresource (2.3.14)
  * activesupport (2.3.14)
  * bundler (1.1.3)
  * coderay (1.0.6)
  * fastercsv (1.5.4)
  * i18n (0.4.2)
  * mysql (2.8.1)
  * net-ldap (0.3.1)
  * rack (1.1.3)
  * rails (2.3.14)
  * rake (0.9.2.2)
  * ruby-openid (2.1.8)
  * sqlite3 (1.3.6)
  * tzinfo (0.3.33)

And this:

/opt/ruby-enterprise-1.8.7-2011.03/bin/gem env

Outputs:
RubyGems Environment:
  - RUBYGEMS VERSION: 1.4.2
  - RUBY VERSION: 1.8.7 (2011-02-18 patchlevel 334) [x86_64-linux]
  - INSTALLATION DIRECTORY: /opt/ruby-enterprise-1.8.7-2011.03/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: /opt/ruby-enterprise-1.8.7-2011.03/bin/ruby
  - EXECUTABLE DIRECTORY: /opt/ruby-enterprise-1.8.7-2011.03/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /opt/ruby-enterprise-1.8.7-2011.03/lib/ruby/gems/1.8
     - /root/.gem/ruby/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

I also tried to symlink, /opt/ruby-enterprise-1.8.7-2011.03/bin/bundle binary to /usr/bin/bundle, but with no luck.

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

I've just tried to modify config/preinitializer.rb as follow, just to see:

begin
  require "rubygems" 
  #require "bundler" 
  require "/opt/ruby-enterprise-1.8.7-2011.03/lib/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb" 

No luck...

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

You can try to getr more error information:

begin
  require "rubygems" 
  require "bundler" 
rescue LoadError => e
  $stderr.puts "Redmine requires Bundler. Please install it with `gem install bundler`. #{e.inspect}" 
  exit 1
end

RubyGems is a bit old, you could also try to gem update --system, but I'm not sure if it could matter.

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

Did update RubyGems, but as you expected, no luck.

And with the debug statement, not so surprisingly:

#<LoadError: no such file to load -- bundler>

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

So I modified config/preinitializer.rb once again:

begin
  require "rubygems" 
  #require "bundler" 
  require "/opt/ruby-enterprise-1.8.7-2011.03/lib/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb" 
rescue LoadError => e
  $stderr.puts "Redmine requires Bundler. Please install it with `gem install bundler`. #{e.inspect}" 
  exit 1
end

And the error message is now:

#<LoadError: no such file to load -- bundler/psyched_yaml>

Which looks really similar to: http://www.redmine.org/boards/2/topics/30488

As a side note, I'm on Debian Lenny. But I don't see any reason why this would matter.

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

... which is strange since:

ll /opt/ruby-enterprise-1.8.7-2011.03/lib/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler
total 260
-rw-rw-r-- 1 root root   456 2012-05-15 09:54 capistrano.rb
-rw-rw-r-- 1 root root 25451 2012-05-15 09:54 cli.rb
-rw-rw-r-- 1 root root 15926 2012-05-15 09:54 definition.rb
-rw-rw-r-- 1 root root  3095 2012-05-15 09:54 dependency.rb
-rw-rw-r-- 1 root root  2714 2012-05-15 09:54 deployment.rb
-rw-rw-r-- 1 root root   601 2012-05-15 09:54 dep_proxy.rb
-rw-rw-r-- 1 root root  8109 2012-05-15 09:54 dsl.rb
-rw-rw-r-- 1 root root  1874 2012-05-15 09:54 endpoint_specification.rb
-rw-rw-r-- 1 root root   804 2012-05-15 09:54 environment.rb
-rw-rw-r-- 1 root root  7622 2012-05-15 09:54 fetcher.rb
-rw-rw-r-- 1 root root  4122 2012-05-15 09:54 gem_helper.rb
-rw-rw-r-- 1 root root   480 2012-05-15 09:54 gem_helpers.rb
-rw-rw-r-- 1 root root   218 2012-05-15 09:54 gem_installer.rb
-rw-rw-r-- 1 root root    62 2012-05-15 09:54 gem_tasks.rb
-rw-rw-r-- 1 root root  5051 2012-05-15 09:54 graph.rb
-rw-rw-r-- 1 root root  4701 2012-05-15 09:54 index.rb
-rw-rw-r-- 1 root root  5343 2012-05-15 09:54 installer.rb
-rw-rw-r-- 1 root root  1870 2012-05-15 09:54 lazy_specification.rb
-rw-rw-r-- 1 root root  3796 2012-05-15 09:54 lockfile_parser.rb
drwxr-xr-x 2 root root  4096 2012-05-15 09:54 man
-rw-rw-r-- 1 root root   266 2012-05-15 09:54 match_platform.rb
-rw-rw-r-- 1 root root   271 2012-05-15 09:54 psyched_yaml.rb      # <-----
-rw-rw-r-- 1 root root  1637 2012-05-15 09:54 remote_specification.rb
-rw-rw-r-- 1 root root 17796 2012-05-15 09:54 resolver.rb
-rw-rw-r-- 1 root root  3744 2012-05-15 09:54 rubygems_ext.rb
-rw-rw-r-- 1 root root 10065 2012-05-15 09:54 rubygems_integration.rb
-rw-rw-r-- 1 root root  7486 2012-05-15 09:54 runtime.rb
-rw-rw-r-- 1 root root  3057 2012-05-15 09:54 settings.rb
-rw-rw-r-- 1 root root   637 2012-05-15 09:54 setup.rb
-rw-rw-r-- 1 root root  1742 2012-05-15 09:54 shared_helpers.rb
-rw-rw-r-- 1 root root 21548 2012-05-15 09:54 source.rb
-rw-rw-r-- 1 root root  3138 2012-05-15 09:54 spec_set.rb
drwxr-xr-x 3 root root  4096 2012-05-15 09:54 templates
-rw-rw-r-- 1 root root  1663 2012-05-15 09:54 ui.rb
drwxr-xr-x 4 root root  4096 2012-05-15 09:54 vendor
-rw-rw-r-- 1 root root   230 2012-05-15 09:54 vendored_thor.rb
-rw-rw-r-- 1 root root   219 2012-05-15 09:54 version.rb
-rw-rw-r-- 1 root root   331 2012-05-15 09:54 vlad.rb

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

Also, check that your GEM_HOME environment variable is not set to some weird location?

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

Or try to set it to /opt/ruby-enterprise-1.8.7-2011.03/lib/ruby/gems/1.8/.

RE: Redmine requires Bundler. But it's there!! - Added by Jérémy Chatard about 7 years ago

Ah ah !

Fetching: psych-1.3.2.gem (100%)
ERROR:  Error installing psych:
    psych requires Ruby version >= 1.9.2.

And echo $GEM_HOME returns an empty output.

RE: Redmine requires Bundler. But it's there!! - Added by Diluen Cheong about 7 years ago

echo $GEM_HOME returns an empty output.

gem install psych returns an error. Something about yaml.h is missing.

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

Yeah but I still don't think it matters since I think Psych has never been installable with 1.8.

What's your gem list?

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

I don't think it will work neither, but try to force $GEM_HOME?

RE: Redmine requires Bundler. But it's there!! - Added by Diluen Cheong about 7 years ago

Etienne Massip wrote:

Yeah but I still don't think it matters since I think Psych has never been installable with 1.8.

What's your gem list?

  • LOCAL GEMS ***

actionmailer (3.2.3)
actionpack (3.2.3)
activemodel (3.2.3)
activerecord (3.2.3)
activeresource (3.2.3)
activesupport (3.2.3)
acts-as-taggable-on (2.2.2)
acts_as_list (0.1.6)
arel (3.0.2)
bcrypt-ruby (3.0.1)
blankslate (2.1.2.4)
bootstrap-sass (2.0.2)
builder (3.0.0)
bundler (1.1.3)
carrierwave (0.6.2)
charlock_holmes (0.6.8)
coderay (1.0.6)
coffee-rails (3.2.2)
coffee-script (2.2.0)
coffee-script-source (1.3.1)
colored (1.2)
daemon_controller (1.0.0)
daemons (1.1.8)
devise (2.0.4)
diff-lcs (1.1.3)
drapper (0.8.4)
erubis (2.7.0)
escape_utils (0.2.4)
eventmachine (0.12.10)
execjs (1.3.2)
faker (1.0.1)
fastthread (1.0.7)
ffi (1.0.11)
foreman (0.46.0)
git (1.2.5)
haml (3.1.5)
haml-rails (0.3.4)
hashery (1.5.0)
hashie (1.2.0)
hike (1.2.1)
httparty (0.8.3)
i18n (0.6.0)
journey (1.0.3)
jquery-rails (2.0.2)
json (1.7.3)
kaminari (0.13.0)
kgio (2.7.4)
libv8 (3.3.10.4 x86_64-linux)
mail (2.4.4)
metaclass (0.0.1)
mime-types (1.18)
minitest (3.0.0)
mocha (0.11.4)
modularity (0.6.1)
multi_json (1.3.5)
multi_xml (0.5.1)
mysql (2.8.1)
mysql2 (0.3.11)
net-ldap (0.3.1)
omniauth (1.1.0)
omniauth-ldap (1.0.2)
orm_adapter (0.0.7)
passenger (3.0.12)
pg (0.13.2)
polyglot (0.3.3)
posix-spawn (0.3.6)
prototype-rails (3.2.1)
pygments.rb (0.2.12)
pyu-ruby-sasl (0.0.3.3)
rack (1.4.1)
rack-cache (1.2)
rack-openid (1.3.1)
rack-protection (1.2.0)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.2.3)
railties (3.2.3)
raindrops (0.8.0)
rake (0.9.2.2)
rdoc (3.12)
redcarpet (2.1.1)
redis (2.2.2)
redis-namespace (1.1.0)
resque (1.20.0)
rmagick (2.13.1)
ruby-openid (2.1.8)
rubygems-update (1.8.24)
rubyntlm (0.1.1)
rubypython (0.6.0)
sass (3.1.17)
sass-rails (3.2.5)
seed-fu (2.2.0)
shoulda (2.11.3)
sinatra (1.3.2)
six (0.2.0)
sprockets (2.4.2, 2.1.3)
sqlite3 (1.3.6)
sqlite3-ruby (1.3.3)
stamp (0.1.6)
term-ansicolor (1.0.7)
therubyracer (0.10.1)
thin (1.3.1)
thor (0.15.2, 0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (0.3.33)
uglifier (1.2.4)
unicorn (4.3.1)
vegas (0.1.11)
warden (1.2.0)

RE: Redmine requires Bundler. But it's there!! - Added by Diluen Cheong about 7 years ago

Here's the screenshot of my error when I try to load up Redmine in my browser.

RE: Redmine requires Bundler. But it's there!! - Added by Etienne Massip about 7 years ago

Diluen Cheong wrote:

Here's the screenshot of my error when I try to load up Redmine in my browser.

Seems not to be the same issue: Redmine requires Redmine 1.0.21 (you're using 1.0.15). Please install a newer version with 'gem install bundler'

1 2 (1-25/34)