SOLVED: Cannot upgrade to 1.4.1 Warning about "You cannot specify the same gem twice"

Added by Steve F. over 7 years ago

I posted the same question on bitnami forum, lots of views but no replies.

I installed brand new installation of redmine 1.3.2 (everything running fine)

When I am running 1.4.1 module upgrade I am getting the following warning now and apache do not start after upgrade finished (log says apache server getting stop command)

Warning: 
Problem running post-install step. Installation may not complete correctly. Error running c:\program files\bitnami redmine stack/apps/redmine\scripts\redmineini.bat : rake aborted! c:/program files/bitnami redmine stack/ruby/lib/ruby/gems/1.8/gems/bundler-1.021/lib/bundler/dsl.rb:68:in 'gem': You cannot specify the same gem twice with different version requirements. you specified: i18n(~>0.4.2) and i18n (=0.4.2)

That warning is above my level of expertise. Any help pointing me in right direction is appreciated.

Searching the web, I saw a mentioning that it can be caused by some plugin.

my current plugins are:

Issue Hot Buttons 0.3
Redmine Auto Done 100% 0.0.1
Better Gantt Chart 0.6.5
Issue Checklist 1.0.0
Knowledgebase 0.3.3
Periodictask 0.0.1
Monitoramento & Controle 1.0.0

All plugins are working fine on 1.3.2

Replies (4)

RE: Cannot upgrade to 1.4.1 Warning about "You cannot specify the same gem twice" - Added by Jean-Philippe Lang over 7 years ago

Redmine core and one of your plugins seem to have 2 requirements for the same gem (i18n).
Look for a Gemfile in your plugins that contains something like gem "i18n", "0.4.2". If it's the case, you can remove this line without too much risk. Just my 2 cents!

RE: Cannot upgrade to 1.4.1 Warning about "You cannot specify the same gem twice" - Added by Steve F. over 7 years ago

whole /redmine folder contain two files:

gemfile and gemfile.lock. both in better gantt chart plugin folder

source <link removed as it not allows me to add comment>
source <link removed as it not allows me to add comment>

group :test do
  gem 'rake'
  gem 'sqlite3'
  gem 'mysql'
  gem 'rspec', "~>1.3" 
  gem 'rspec-rails', "~>1.3" 
  gem 'factory_girl', "~>1.3" 
  gem 'database_cleaner'
  gem 'test-unit', '1.2.3'
  gem 'RedCloth', "~> 4.2.9" 
end

GEM
  remote: <link removed as it not allows me to add comment>
  remote: <link removed as it not allows me to add comment>
  specs:
    RedCloth (4.2.9)
    database_cleaner (0.6.7)
    factory_girl (1.3.3)
    hoe (2.12.3)
      rake (~> 0.8)
    mysql (2.8.1)
    rack (1.1.0)
    rake (0.9.2)
    rspec (1.3.2)
    rspec-rails (1.3.4)
      rack (>= 1.0.0)
      rspec (~> 1.3.1)
    sqlite3 (1.3.4)
    test-unit (1.2.3)
      hoe (>= 1.5.1)

PLATFORMS
  ruby

DEPENDENCIES
  RedCloth (~> 4.2.9)
  database_cleaner
  factory_girl (~> 1.3)
  mysql
  rake
  rspec (~> 1.3)
  rspec-rails (~> 1.3)
  sqlite3
  test-unit (= 1.2.3)

EDIT:

whole bitnami redmine stack folder contains 23 files with "gemfile" in its name, none of them have i18n or 0.4.2 inside.

EDIT2:
gem query list i18n gem as local gem, but where else it can be found?

RE: Cannot upgrade to 1.4.1 Warning about "You cannot specify the same gem twice" - Added by Steve F. over 7 years ago

PROBLEM SOLVED:

Step1. Remove GEMFILE and GEMFILE.LOCK from "better gantt chart" plugin folder.
Step2. Run Module Update
Step3. after update, redmine.conf file in \apps\redmine\conf folder contain an extra line </Proxy> after removing that line everything seems to work

(1-4/4)