undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468>

Added by Vladimir Karandin over 5 years ago

Please tell me the direction in solving the problem:
rake generate_secret_token ?

[root@localv www]# cd /var/www/redmine-2.0
[root@localv redmine-2.0]# bundle install --without development test
Fetching gem metadata from http://rubygems.org/.......
Using rake (0.9.2.2)
Using i18n (0.6.0)
Using multi_json (1.3.6)
Using activesupport (3.2.3)
Using builder (3.0.0)
Using activemodel (3.2.3)
Using erubis (2.7.0)
Using journey (1.0.3)
Using rack (1.4.1)
Using rack-cache (1.2)
Using rack-test (0.6.1)
Using hike (1.2.1)
Using tilt (1.3.3)
Using sprockets (2.1.3)
Using actionpack (3.2.3)
Using mime-types (1.18)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.4.4)
Using actionmailer (3.2.3)
Using arel (3.0.2)
Using tzinfo (0.3.33)
Using activerecord (3.2.3)
Using activeresource (3.2.3)
Using bundler (1.1.4)
Using coderay (1.0.6)
Using json (1.7.3)
Using mysql2 (0.3.11)
Using net-ldap (0.3.1)
Using pg (0.13.2)
Using rack-ssl (1.3.2)
Using rdoc (3.12)
Using thor (0.14.6)
Using railties (3.2.3)
Using rails (3.2.3)
Using prototype-rails (3.2.1)
Using ruby-openid (2.1.8)
Using rack-openid (1.3.1)
Using rmagick (2.13.1)
Using sqlite3 (1.3.6)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed

---------
[root@localv redmine-2.0]# rake generate_secret_token --trace
rake aborted!
undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468>
/usr/local/share/gems/gems/railties-3.2.3/lib/rails/railtie/configuration.rb:85:in `method_missing'
/var/www/redmine-2.0/config/application.rb:26:in `<class:Application>'
/var/www/redmine-2.0/config/application.rb:13:in `<module:RedmineApp>'
/var/www/redmine-2.0/config/application.rb:12:in `<top (required)>'
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
/var/www/redmine-2.0/Rakefile:5:in `<top (required)>'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in `load'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in `load_rakefile'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:501:in `raw_load_rakefile'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:82:in `block in load_rakefile'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:81:in `load_rakefile'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:65:in `block in run'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/usr/share/gems/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
/bin/rake:32:in `<main>'

thank you

Replies (15)

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Steve Short over 5 years ago

I'm getting the same error on a new, clean Fedora 17 install. Any clues, guys?

Thx
S

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Steve Short over 5 years ago

Yes. I can log in using the same database and credentials as specified in the database.yml file and create a test table.

S

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Steve Short over 5 years ago

Yes - still get undefined method `active_record' for Rails::Application::Configuration.

S.

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Yevhen Kyrylchenko over 5 years ago

I must confirm problem.
I just upgrade Fedora from 16 to 17 and can't run redmin.
Error is:

undefined method `active_record' for #<Rails::Application::Configuration:0x00000001ff05e0>

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Charlie Mordant over 5 years ago

Hi,

Same problem here, exactly the same config as Steve, same error when I launch Webrick.
Don't work for 2.0-Stable and 2.0.2.

Regards

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Igor Siap over 5 years ago

I have the same problem with 2.0-Stable and fedora 17.
Could you tell me please when it will be fixed?
Thanks

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Etienne Massip over 5 years ago

As it seems to happen with a new Rails application and Fedora 17, I'd rather ask the question in Fedora forums if I were you.

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Steve Short over 5 years ago

Here is a good place to start as it could well be a dependency issue.
Bet if we posted over there they'd send us back here ;)

S.

RE: undefined method `active_record' for #<Rails::Application::Configuration:0x00000001af6468> - Added by Charlie Mordant over 5 years ago

I've filled a bug, if you want to follow: https://bugzilla.redhat.com/show_bug.cgi?id=829209

apparently, bigdecimal is not the cause, can you search a little more (as me in my side)?

Best

(1-15/15)