Trying to update plugins result in rake aborted

Added by Alessio Pollero over 5 years ago

I am trying to update redmine plugin with the command :

rake db:migrate_plugins RAILS_ENV=production

but i'm getting this error :

(in /usr/share/redmine)
rake aborted!
Could not find RubyGem rack (~> 1.1.0)
/usr/share/redmine/vendor/rails/railties/lib/initializer.rb:271:in `rescue in require_frameworks'
/usr/share/redmine/vendor/rails/railties/lib/initializer.rb:268:in `require_frameworks'
/usr/share/redmine/vendor/rails/railties/lib/initializer.rb:134:in `process'
/usr/share/redmine/vendor/rails/railties/lib/initializer.rb:113:in `run'
/usr/share/redmine/config/environment.rb:24:in `<top (required)>'
<internal:lib/rubygems/custom_require>:29:in `require'
<internal:lib/rubygems/custom_require>:29:in `require'
/usr/share/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `block in require'
/usr/share/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in `new_constants_in'
/usr/share/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
/usr/share/redmine/vendor/rails/railties/lib/tasks/misc.rake:4:in `block in <top (required)>'
/usr/lib/ruby/1.9.1/rake.rb:634:in `call'
/usr/lib/ruby/1.9.1/rake.rb:634:in `block in execute'
/usr/lib/ruby/1.9.1/rake.rb:629:in `each'
/usr/lib/ruby/1.9.1/rake.rb:629:in `execute'
/usr/lib/ruby/1.9.1/rake.rb:595:in `block in invoke_with_call_chain'
/usr/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize'
/usr/lib/ruby/1.9.1/rake.rb:588:in `invoke_with_call_chain'
/usr/lib/ruby/1.9.1/rake.rb:605:in `block in invoke_prerequisites'
/usr/lib/ruby/1.9.1/rake.rb:602:in `each'
/usr/lib/ruby/1.9.1/rake.rb:602:in `invoke_prerequisites'
/usr/lib/ruby/1.9.1/rake.rb:594:in `block in invoke_with_call_chain'
/usr/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize'
/usr/lib/ruby/1.9.1/rake.rb:588:in `invoke_with_call_chain'
/usr/lib/ruby/1.9.1/rake.rb:581:in `invoke'
/usr/lib/ruby/1.9.1/rake.rb:2041:in `invoke_task'
/usr/lib/ruby/1.9.1/rake.rb:2019:in `block (2 levels) in top_level'
/usr/lib/ruby/1.9.1/rake.rb:2019:in `each'
/usr/lib/ruby/1.9.1/rake.rb:2019:in `block in top_level'
/usr/lib/ruby/1.9.1/rake.rb:2058:in `standard_exception_handling'
/usr/lib/ruby/1.9.1/rake.rb:2013:in `top_level'
/usr/lib/ruby/1.9.1/rake.rb:1992:in `run'
/usr/bin/rake:28:in `<main>'

Redmine Version : 1.3.0
Ruby Version : ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-linux]
Rails Version : Rails 2.3.5

Why ?
How can i solve this problem ?

Replies (1)

RE: Trying to update plugins result in rake aborted - Added by SY H over 5 years ago

Line 3 : Could not find RubyGem rack (~> 1.1.0)

I think that you should install "rack" on your system.

try this before update your plugin.
: gem install rack

(1-1/1)