Trouble With Upgrading

Added by Chris Leonard over 9 years ago

Hi All,
Last summer I installed redmine 0.5.1 and used it for several months. In December I unsuccessfully tried to upgrade to 0.6.0, I got the "Application Error Rails application failed to start properly" error. I tried for about a week to get it running again, and threw in the towel with hopes that a later version would help.

This morning I tried upgrading to 0.6.4, and once again I'm getting the application error. I am very interested in getting this running again. I've been using Voo2do, and I'm ready to come back. I'm very green on Ruby. Please let me know what (if any) information I can provide which will be helpful in troubleshooting.

Some details:
I'm running this on a Site5 shared hosting plan.
Mongrel and Webrick are against my terms of service so I have to use fast CGI.

Thanks In Advance,
Chris

Replies (5)

RE: Trouble With Upgrading - Added by Thomas Lecavelier over 9 years ago

Hello Chris,

To start it right, have you launch the migration commands (rake db:migrate RAILS_ENV=production) and does it run fine? Then when using fastCGI, you have to restart not only the redmine processes but the fcgi processes too (not only the webserver running the fcgi) to get the changes into account.
If your redmine is not up after that, please consider pasting your log/production.log file in a pastie and put the link here.

Thank you.

RE: Trouble With Upgrading - Added by Chris Leonard over 9 years ago

The rake command runs without a hitch. I did check my log/production.log and its just a list of migration commands. Does this mean that there's a problem with my dispatch.fcgi? I'm using the same one that worked with redmine 0.5.1, I just copied and pasted it into the public folder within 0.6.4. Is that okay?

Thanks,
Chris

RE: Trouble With Upgrading - Added by Thomas Lecavelier over 9 years ago

Before talking about fcgi, could you try your redmine instance just through webrick or mongrel (ruby script/server -e production). Does it run fine?

If so, your fcgi script seems to have a problem.

RE: Trouble With Upgrading - Added by Chris Leonard over 9 years ago

I tried that just now, and it does work properly. Why would my fcgi work with 0.5.1 and not 0.6.4? That doesn't make sense to me.

Thanks,
Chris

RE: Trouble With Upgrading - Added by Chris Leonard over 9 years ago

I've spent some time further experimenting, and I needed to update my .htaccess and the dispatch.fcgi file wasn't executable. Now I've taken care of those pieces, and when I hit the site I get "Mysql::Error in WelcomeController#index". When I start Mongrel it works, when I use fcgi it gives an error. I'm making progress, but I'm not sure where to go from here.

Thanks,
Chris

(1-5/5)