LDAP Not valid users

Added by jhony gonzalez over 9 years ago

I Create a connection with an active directory And displays the message that if it connects and i don´t know that make And when I go to connect tells me that i don´t have any user registered

Replies (5)

RE: LDAP Not valid users - Added by Thomas Lecavelier over 9 years ago

What a beautiful sentence! Not even a question... My crystal ball is by the repair-man, could you precise your redmine version and your environnement please?

Thank you.

RE: LDAP Not valid users - Added by jhony gonzalez over 9 years ago

My version is

Redmine 0.6.3 (MySQL)

escuse me i don´t speak very well the english

my configuration is next

Name = users
Host = vega
Port = 389
LDAPS = no
Account = ldatest
Password = <password>
Base DN = CN=users,DC=vega,DC=ingeneo,DC=biz

On-the-fly user creation = yes
Attributes
Login = sAMAccountName// i don´t know for that is this
Firstname = givenName
Lastname = sN
Email = mail

RE: LDAP Not valid users - Added by Jason Milkins over 9 years ago

sAMAccontName is the standard Windows login name...

Often this will be configured to allow a name with spaces ... for example "Jhony Gonzalez" ... Redmine doesn't like user names with spaces (although I have patched this on a development installation see #811 and things seem ok.)

We use the LDAP property mailNickname instead of sAMAccountName for our live Redmine install, the value for mailNickName cannot contain spaces (which is an LDAP rule)

mailNickName will most likely be your email name ... e.g. if your email was your mailNickName would be jhony.gonzalez so you would log into Redmine with jhony.gonzalez after setting:
Name = users
Host = vega
Port = 389
LDAPS = no
Account = ldatest
Password = <password>
Base DN = CN=users,DC=vega,DC=ingeneo,DC=biz

On-the-fly user creation = yes
Attributes
Login = mailNickName
Firstname = givenName
Lastname = sN
Email = mail

Hope that helps you out.

RE: LDAP Not valid users - Added by Jason Milkins over 9 years ago

Sorry .. that should be .

mailNickname

RE: LDAP Not valid users - Added by Jason Milkins over 9 years ago

Oh one other thing, check that the connection to the LDAP is valid and that you have the correct port ... Windows Server uses 3268 in some instances (instead of 389)

(1-5/5)