upgrading from 1.3 to latest version

Added by Smokie Smokerson over 6 years ago

Hello,

ive installed redmine 1.3 through ubuntu repo and been using for a while now.

i tried to upgrade to the latest version but now i get this error when i try to open my redmine page:

The application has exited during startup (i.e. during the evaluation of config/environment.rb). The error message can be found below. To solve this problem, please follow any instructions in the error message.

Error message:
    Redmine requires Bundler 1.0.21 (you're using 1.0.15). Please install a newer version with `gem install bundler`. 
Application root:
    /usr/share/redmine 

When i run the command i guet this:


root@mars:/usr/share/redmine# gem install bundler
Successfully installed bundler-1.3.0
1 gem installed
Installing ri documentation for bundler-1.3.0...
Installing RDoc documentation for bundler-1.3.0...

When i run rake generate_session_store, i get this:

root@mars:/usr/share/redmine# rake generate_session_store
WARNING: 'require 'rake/rdoctask'' is deprecated.  Please use 'require 'rdoc/task' (in RDoc 2.4.2+)' instead.
    at /usr/lib/ruby/vendor_ruby/rake/rdoctask.rb

Note: The rake task generate_session_store has been deprecated, please use the replacement version generate_secret_token

When i run generate_secret_token, i get this:

root@mars:/usr/share/redmine# rake generate_secret_token
WARNING: 'require 'rake/rdoctask'' is deprecated.  Please use 'require 'rdoc/task' (in RDoc 2.4.2+)' instead.
    at /usr/lib/ruby/vendor_ruby/rake/rdoctask.rb

Any help will be really appreciated as i use this daily to keep track of what i do at work.

Thank you in advance..

Replies (5)

RE: upgrading from 1.3 to latest version - Added by Jan Niggemann (redmine.org team member) over 6 years ago

What's the error message you're getting now when starting / accessing redmine?

RE: upgrading from 1.3 to latest version - Added by Smokie Smokerson over 6 years ago

Hello,

This is what i get:

The application has exited during startup (i.e. during the evaluation of config/environment.rb). The error message can be found below. To solve this problem, please follow any instructions in the error message.
Error message:
Redmine requires Bundler 1.0.21 (you're using 1.0.15). Please install a newer version with `gem install bundler`.
Application root:
/usr/share/redmine

RE: upgrading from 1.3 to latest version - Added by Smokie Smokerson over 6 years ago

When i run "gem install bundler", this is what i get:

root@mars:/usr/share/redmine# gem install bundler                                                                      Successfully installed bundler-1.3.0
1 gem installed
Installing ri documentation for bundler-1.3.0...
Installing RDoc documentation for bundler-1.3.0...

according to this, doesnt mean bundler-1.3.0 is the one thats installed now?

RE: upgrading from 1.3 to latest version - Added by Jan Niggemann (redmine.org team member) over 6 years ago

Did you follow RedmineUpgrade? I don't have a clue what you might have done...
Where's that error message from? When does it appear? Is it from your application server (which one btw)?

RE: upgrading from 1.3 to latest version - Added by Smokie Smokerson over 6 years ago

Jan Niggemann wrote:

Did you follow RedmineUpgrade? I don't have a clue what you might have done...
Where's that error message from? When does it appear? Is it from your application server (which one btw)?

Hello Jan,

Unfortunately i didnt use that page to upgrade, i used HowTo_Install_Redmine_in_Ubuntu, the upgrade to latest version section but it didnt go as planned..

Right now i just want my data back because i have over 4 months of really important data and really need it back so any help is really really appreciated.

(1-5/5)