Rake : Aborted Unknown validator: 'DateValidator'

Added by David Dupont over 5 years ago

Bonjour à tous ,

J'ai mis à jour ce matin Redmine. J'étais en 2.1

J'ai lancé : rake db:migrate RAILS_ENV=production

Et voici ce que j'obtiens :

Rake aborted !
Unknown validator: 'DateValidator'

Et bien sûr, Remdine ne se lance plus ! :(

Voici ce que j'obtiens lorsque je lance rake -t db:migrate RAILS_ENV=productio

** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
Unknown validator: 'DateValidator'
/var/lib/gems/1.8/gems/activemodel-3.2.8/lib/active_model/validations/validates.rb:96:in `validates'
/var/lib/gems/1.8/gems/activemodel-3.2.8/lib/active_model/validations/validates.rb:90:in `each'
/var/lib/gems/1.8/gems/activemodel-3.2.8/lib/active_model/validations/validates.rb:90:in `validates'
/var/www/redmine/app/models/version.rb:33
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:359:in `require_or_load'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:502:in `load_missing_constant'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:192:in `const_missing'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `each'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `const_missing'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:514:in `load_missing_constant'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:192:in `const_missing'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `each'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `const_missing'
/var/www/redmine/app/models/project.rb:41
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:359:in `require_or_load'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:313:in `depend_on'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:225:in `require_dependency'
/var/www/redmine/plugins/due_date_reminder/init.rb:5:in `_callback_before_5'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:429:in `_run__2144987145__prepare__4__callbacks'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `send'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_prepare_callbacks'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `send'
/var/lib/gems/1.8/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/var/lib/gems/1.8/gems/actionpack-3.2.8/lib/action_dispatch/middleware/reloader.rb:74:in `prepare!'
/var/lib/gems/1.8/gems/actionpack-3.2.8/lib/action_dispatch/middleware/reloader.rb:48:in `prepare!'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/application/finisher.rb:47
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:30:in `instance_exec'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:30:in `run'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:55:in `run_initializers'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:54:in `each'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:54:in `run_initializers'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:136:in `initialize!'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `send'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `method_missing'
/var/www/redmine/config/environment.rb:14
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:103:in `require'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:103:in `require_environment!'
/var/lib/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:295:in `initialize_tasks'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `call'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `execute'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `each'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:116:in `invoke_task'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `each'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:88:in `top_level'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:66:in `run'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/var/lib/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
/var/lib/gems/1.8/gems/rake-0.9.2.2/bin/rake:33
/usr/bin/rake:19:in `load'
/usr/bin/rake:19
Tasks: TOP => db:migrate => environment

Le drame...

Une idée svp ?

Replies (1)

RE: Rake : Aborted Unknown validator: 'DateValidator' - Added by David Dupont over 5 years ago

J'ai oublié de préciser que j'utilise le plugin Due Date Remember

Et j'ai bien lancé la commande rake db:migrate_plugins RAILS_ENV=production

Et j’obtiens la même erreur. :(

Merci d'avance

(1-1/1)