Problem with redmine 1.3 and mysql2 adaptar

Added by kani mambo over 6 years ago

Already instaled mysql2 adapter but it seems to be a problem since i get this error when using apache.

Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` (no such file to load -- active_record/connection_adapters/mysql2_adapter) (RuntimeError)
/var/www/html/redmine/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:76:in `establish_connection'
/var/www/html/redmine/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:60:in `establish_connection'
/var/www/html/redmine/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:55:in `establish_connection'
/var/www/html/redmine/config/../vendor/rails/railties/lib/initializer.rb:438:in `initialize_database'
/var/www/html/redmine/config/../vendor/rails/railties/lib/initializer.rb:141:in `process'
/var/www/html/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
/var/www/html/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
/var/www/html/redmine/config/environment.rb:24
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.10/helper-scripts/classic-rails-preloader.rb:69:in `preload_app'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.10/helper-scripts/classic-rails-preloader.rb:156

It works fine with passenger and webrick but with apache i keep getting this errors.

regards kanimambo.

Replies (2)

RE: Problem with redmine 1.3 and mysql2 adaptar - Added by kani mambo over 6 years ago

gem list:

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activerecord-mysql2-adapter (0.0.3)
activeresource (2.3.14)
activesupport (2.3.14)
atomic (1.1.10)
bundle (0.0.1)
bundler (1.3.5)
cgi_multipart_eof_fix (2.5.0)
coderay (1.0.9, 0.9.8)
daemon_controller (1.1.5)
daemons (1.1.9)
fastthread (1.0.7)
gem_plugin (0.2.3)
hoe (3.7.0)
i18n (0.6.4, 0.4.2)
json (1.8.0)
minitest (5.0.6, 4.7.5)
mongrel (1.1.5)
multi_json (1.7.7)
mysql (2.9.1, 2.8.1)
mysql2 (0.2.7)
passenger (4.0.10)
rack (1.5.2, 1.1.2, 1.1.0)
rails (2.3.14)
rake (10.1.0, 0.8.3)
RedCloth (4.2.9)
rubytree (0.8.3, 0.5.2)
structured_warnings (0.1.4)
thread_safe (0.1.2)
tzinfo (1.0.1, 0.3.37)

RE: Problem with redmine 1.3 and mysql2 adaptar - Added by Jan Niggemann (redmine.org team member) over 6 years ago

RM 1.3 is no longer supported, and it has security issues. Rails 2.3.14 is vulnerable to attacks.
That said, IIRC you must use the 0.2 version of the mysql2 gem for rails 2.3.x versions...

(1-2/2)