Index of /redmine page at the login, after installation on ubuntu 14.04 server

Added by Matteo Marzo over 4 years ago

Hi everybody,
I'm Matteo and I'm trying to install redmine on my ubuntu 14.04 server.

I followed this guide:
http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_25x_on_Ubuntu_1404_with_Apache2_Phusion_Passenger_MySQL_and_Subversion

But... even if I did everything step by step, when I type:
http://myhost/redmine
I get the Index of /redmine page (whose I'm attaching a screenshot) and cannot access the web application.

Is there anybody helping me?
Thanks in advance.

Matteo

screenshot.png (105 KB)

Replies (12)

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Matteo Marzo over 4 years ago

Nobody to help me?
I'm sorry if I'm re-typing, but this place is the only one where I can find some help.
Hope you would support me.
Regards.

Matteo

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Leonel Iturralde over 4 years ago

Hi,
Which version of redmine did you install?
Can you run redmine from webrick?
--

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Matteo Marzo over 4 years ago

Hi Leonel and many thanks for your reply ;)

My redmine version is 2.5 as per:
http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_25x_on_Ubuntu_1404_with_Apache2_Phusion_Passenger_MySQL_and_Subversion

How do I run redmine from webrick? Can you give me further instructions?

Matteo

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Leonel Iturralde over 4 years ago

I thought you were using that tutorial to install a more updated redmine.
To run webrick

bundle exec ruby script/rails server webrick -e production

Edit:
I think there must be a problem with apache configuration.

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Matteo Marzo over 4 years ago

I ran webrick and got the following output:

Could not locate Gemfile or .bundle/ directory

How would I proceed?
Thaks.

Matteo

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Leonel Iturralde over 4 years ago

Hi,
you ran the command in the same folder where redmine is installed ? based on the HowTo must be /usr/share/redmine

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Matteo Marzo over 4 years ago

Ok, sorry, I pointed the proper folder and got the following output:

/var/lib/gems/1.9.1/gems/bundler-1.9.6/lib/bundler/shared_helpers.rb:78: warning: Insecure world writable dir /home in PATH, mode 040777
/var/lib/gems/1.9.1/gems/bundler-1.9.6/lib/bundler/shared_helpers.rb:78: warning: Insecure world writable dir /home in PATH, mode 040777
=> Booting WEBrick
=> Rails 3.2.19 application starting in production on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/lib/ruby/1.9.1/fileutils.rb:247:in `mkdir': Permission denied - /usr/share/redmine/tmp/pids (Errno::EACCES)
from /usr/lib/ruby/1.9.1/fileutils.rb:247:in `fu_mkdir'
from /usr/lib/ruby/1.9.1/fileutils.rb:221:in `block (2 levels) in mkdir_p'
from /usr/lib/ruby/1.9.1/fileutils.rb:219:in `reverse_each'
from /usr/lib/ruby/1.9.1/fileutils.rb:219:in `block in mkdir_p'
from /usr/lib/ruby/1.9.1/fileutils.rb:205:in `each'
from /usr/lib/ruby/1.9.1/fileutils.rb:205:in `mkdir_p'
from /var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/commands/server.rb:67:in `block in start'
from /var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/commands/server.rb:66:in `each'
from /var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/commands/server.rb:66:in `start'
from /var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/commands.rb:55:in `block in <top (required)>'
from /var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/commands.rb:50:in `tap'
from /var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/commands.rb:50:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Leonel Iturralde over 4 years ago

Change your apache2 config file in the part where you set RailsBaseURI
From this:

<Directory /var/www/html/redmine>
    RailsBaseURI /redmine
    PassengerResolveSymlinksInDocumentRoot on
</Directory>

To this:
<Directory /var/www/html/redmine>
    PassengerBaseURI /redmine
    PassengerAppRoot /usr/share/redmine
    PassengerResolveSymlinksInDocumentRoot on
</Directory>

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Matteo Marzo over 4 years ago

Ok, just done, and restarted apache2:

sudo a2enmod passenger
sudo service apache2 restart

but when I type:

http://myhost/redmine

I get the Index of /redmine page again...

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Matteo Marzo over 4 years ago

Following this post on the forum

http://www.redmine.org/boards/2/topics/43395

I type:

passenger-status

and got:

ERROR: Phusion Passenger doesn't seem to be running. If you are sure that it is running, then the causes of this problem could be:

1. You customized the instance registry directory using Apache's PassengerInstanceRegistryDir option, Nginx's passenger_instance_registry_dir option, 
or Phusion Passenger Standalone's --instance-registry-dir command line argument. If so, please set the environment variable 
PASSENGER_INSTANCE_REGISTRY_DIR to that directory and run passenger-status again.

2. The instance directory has been removed by an operating system background service. Please set a different instance registry directory using Apache's 
PassengerInstanceRegistryDir option, Nginx's passenger_instance_registry_dir option, or Phusion Passenger Standalone's --instance-registry-dir command 
line argument.

Could it help to find a solution?
Thanks

Matteo

RE: Index of /redmine page at the login, after installation on ubuntu 14.04 server - Added by Leonel Iturralde over 4 years ago

Hi,
I think it has something to do with apache config files.
Trying checking that this options are set.

PassengerEnabled On
PassengerRuby path/to/ruby

(1-12/12)