Redmin on Windows Vista - Problem in Installation

Added by Humayun S M over 9 years ago

Hi guys,

I am following the Installation Guide, but I am unable to successfully run follwing command:

C:\redmine-0.8.2>rake db:migrate RAILS_ENV="production"
(in C:/redmine-0.8.2)
rake aborted!
wrong number of arguments (3 for 1)
C:/redmine-0.8.2/rakefile:10
(See full trace by running task with --trace)

Following si my environment related information:

C:\redmine-0.8.2>ruby script/about
About your application's environment
Ruby version 1.8.6 (i386-mswin32)
RubyGems version 1.3.1
Rails version 2.1.2
Active Record version 2.1.2
Action Pack version 2.1.2
Active Resource version 2.1.2
Action Mailer version 2.1.2
Active Support version 2.1.2
Application root C:/redmine-0.8.2
Environment development
Database adapter mysql

I am using Windows Vista Home and MySQL 5.1 Community Server

Would you guys help me? I don't know what I am missing here.

regards,

Humayun.

Replies (6)

RE: Redmin on Windows Vista - Problem in Installation - Added by Evgeny Martynenkov over 9 years ago

Microsoft Windows XP [Версия 5.1.2600]
@
C:\redmine-0.8.3>rake db:migrate RAILS_ENV="production" --trace
(in C:/redmine-0.8.3)
rake aborted!
wrong number of arguments (3 for 1)
C:/redmine-0.8.3/vendor/plugins/engines/tasks/engines.rake:47:in `task'
C:/redmine-0.8.3/vendor/plugins/engines/tasks/engines.rake:47
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1571:in `in_namespace'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:641:in `namespace'
C:/redmine-0.8.3/vendor/plugins/engines/tasks/engines.rake:33
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1571:in `in_namespace'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:641:in `namespace'
C:/redmine-0.8.3/vendor/plugins/engines/tasks/engines.rake:32
C:/redmine-0.8.3/vendor/rails/activesupport/lib/active_support/dependencies.rb:5
03:in `load'
C:/redmine-0.8.3/vendor/rails/activesupport/lib/active_support/dependencies.rb:5
03:in `load'
C:/redmine-0.8.3/vendor/rails/activesupport/lib/active_support/dependencies.rb:3
55:in `new_constants_in'
C:/redmine-0.8.3/vendor/rails/activesupport/lib/active_support/dependencies.rb:5
03:in `load'
C:/redmine-0.8.3/vendor/rails/railties/lib/tasks/rails.rb:7
C:/redmine-0.8.3/vendor/rails/railties/lib/tasks/rails.rb:7:in `each'
C:/redmine-0.8.3/vendor/rails/railties/lib/tasks/rails.rb:7
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_re
quire'
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
C:/redmine-0.8.3/rakefile:10
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `load'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `raw_load_rakefile
'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1727:in `load_rakefile'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exceptio
n_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1726:in `load_rakefile'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1710:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exceptio
n_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
c:/ruby/bin/rake:16:in `load'
c:/ruby/bin/rake:16

C:\redmine-0.8.3>@

RE: Redmin on Windows Vista - Problem in Installation - Added by Evgeny Martynenkov over 9 years ago

No thoughts on this?
On redmine v. 0.7.3 everything is fine.

RE: Redmin on Windows Vista - Problem in Installation - Added by Evgeny Martynenkov over 9 years ago

With Application root "C:/redmine" same problems.
Please, help.

RE: Redmin on Windows Vista - Problem in Installation - Added by Felix Prüll over 9 years ago

Hi all,

I ran into the same problem today, when i tried to update from 0.8.0 to 0.8.3 (OS: Windows Server 2008)
See cmd output below.

I searched around several forums, but i didn't get it.
Does anyone have a hint for us?

Thanks and Regards
Felix

C:\redmine>ruby script/about
About your application's environment
Ruby version              1.8.6 (i386-mswin32)
RubyGems version          0.9.4
Rails version             2.1.2
Active Record version     2.1.2
Action Pack version       2.1.2
Active Resource version   2.1.2
Action Mailer version     2.1.2
Active Support version    2.1.2
Application root          C:/redmine
Environment               development
Database adapter          mysql

C:\redmine>rake db:migrate RAILS_ENV="production" --trace
(in C:/redmine)
rake aborted!
wrong number of arguments (3 for 1)
C:/redmine/vendor/plugins/engines/tasks/engines.rake:47:in `task'
C:/redmine/vendor/plugins/engines/tasks/engines.rake:47
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1571:in `in_namespace'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:641:in `namespace'
C:/redmine/vendor/plugins/engines/tasks/engines.rake:33
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1571:in `in_namespace'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:641:in `namespace'
C:/redmine/vendor/plugins/engines/tasks/engines.rake:32
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:503:in
`load'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:503:in
`load'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in
`new_constants_in'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:503:in
`load'
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:7
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:7:in `each'
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:7
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_re
quire'
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
C:/redmine/rakefile:10
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `load'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `raw_load_rakefile
'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1727:in `load_rakefile'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exceptio
n_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1726:in `load_rakefile'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1710:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exceptio
n_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
c:/ruby/bin/rake:16:in `load'
c:/ruby/bin/rake:16

C:\redmine>rake db:migrate_plugins RAILS_ENV="production" --trace
(in C:/redmine)
rake aborted!
wrong number of arguments (3 for 1)
C:/redmine/vendor/plugins/engines/tasks/engines.rake:47:in `task'
C:/redmine/vendor/plugins/engines/tasks/engines.rake:47
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1571:in `in_namespace'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:641:in `namespace'
C:/redmine/vendor/plugins/engines/tasks/engines.rake:33
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1571:in `in_namespace'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:641:in `namespace'
C:/redmine/vendor/plugins/engines/tasks/engines.rake:32
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:503:in
`load'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:503:in
`load'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:in
`new_constants_in'
C:/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:503:in
`load'
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:7
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:7:in `each'
C:/redmine/vendor/rails/railties/lib/tasks/rails.rb:7
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_re
quire'
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
C:/redmine/rakefile:10
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `load'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `raw_load_rakefile
'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1727:in `load_rakefile'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exceptio
n_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1726:in `load_rakefile'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1710:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exceptio
n_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
c:/ruby/bin/rake:16:in `load'
c:/ruby/bin/rake:16

RE: Redmin on Windows Vista - Problem in Installation - Added by Evgeny Martynenkov over 9 years ago

I've done it!!!
We have RubyGems version 0.9.4 and Rails version 2.1.2
BUT: RubyGems 1.3.1 and Rails 2.2.2 required.

So you must:
1) RubyGems download http://rubyforge.org/frs/download.php/45906/rubygems-1.3.1.zip (then extract and run "setup.rb")
2) Update Rails: run in command line gem install rails --include-dependencies

The end!
P.S. Sorry for my english

(1-6/6)