Problem installing 3.2.0

Added by William Colls almost 4 years ago

Kubuntu 14.04.3 64 bit
Ruby 1.9.3p484

I get the following error message when I try to do the bundle install step:

Installing json 1.8.3 with native extensions

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby1.9.1 extconf.rb
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from extconf.rb:1:in `<main>'

No idea where to go from here.

Suggestions welcome.

Thanks for your time.

William.

Replies (2)

RE: Problem installing 3.2.0 - Added by Gary Pinkham almost 4 years ago

try sudo apt-get install ruby-dev

(or a newer version of ruby)

RE: Problem installing 3.2.0 - Added by William Colls almost 4 years ago

Thank you. That fixed that problem. Now to figure out why rmagick won't build.

(1-2/2)