Unable install plugins on ubuntu 16.04

Added by Surendra Ganne 5 months ago

root@ubuntu:/usr/share/redmine/lib/plugins# rake redmine:plugins:migrate
(in /usr/share/redmine)
rake aborted!
Gem::LoadError: Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord).

/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/connection_adapters/connection_specification.rb:177:in `rescue in spec'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/connection_adapters/connection_specification.rb:174:in `spec'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/connection_handling.rb:50:in `establish_connection'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/railtie.rb:122:in `block (2 levels) in <class:Railtie>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:38:in `instance_eval'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:38:in `execute_hook'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:45:in `block in run_load_hooks'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:44:in `each'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:44:in `run_load_hooks'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/base.rb:315:in `<module:ActiveRecord>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/base.rb:26:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `block in require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `require'
/usr/share/redmine/lib/plugins/acts_as_activity_provider/init.rb:2:in `block in <top (required)>'
/usr/share/redmine/config/initializers/00-core_plugins.rb:12:in `eval'
/usr/share/redmine/config/initializers/00-core_plugins.rb:12:in `block in <top (required)>'
/usr/share/redmine/config/initializers/00-core_plugins.rb:2:in `each'
/usr/share/redmine/config/initializers/00-core_plugins.rb:2:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:268:in `load'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:268:in `block in load'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:268:in `load'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:652:in `block in load_config_initializer'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/notifications.rb:166:in `instrument'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:651:in `load_config_initializer'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:616:in `block (2 levels) in <class:Engine>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:615:in `each'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:615:in `block in <class:Engine>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:30:in `instance_exec'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:30:in `run'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:55:in `block in run_initializers'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:44:in `each'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:44:in `tsort_each_child'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:54:in `run_initializers'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:352:in `initialize!'
/usr/share/redmine/config/environment.rb:14:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:328:in `require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:328:in `require_environment!'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:457:in `block in run_tasks_blocks'
/var/lib/gems/2.3.0/gems/rake-12.0.0/exe/rake:27:in `<top (required)>'
/usr/local/bin/ruby_executable_hooks2.3:15:in `eval'
/usr/local/bin/ruby_executable_hooks2.3:15:in `<main>'
Gem::LoadError: mysql2 is not part of the bundle. Add it to Gemfile.
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/connection_adapters/mysql2_adapter.rb:3:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `block in require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/connection_adapters/connection_specification.rb:175:in `spec'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/connection_handling.rb:50:in `establish_connection'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/railtie.rb:122:in `block (2 levels) in <class:Railtie>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:38:in `instance_eval'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:38:in `execute_hook'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:45:in `block in run_load_hooks'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:44:in `each'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/lazy_load_hooks.rb:44:in `run_load_hooks'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/base.rb:315:in `<module:ActiveRecord>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activerecord/lib/active_record/base.rb:26:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `block in require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:274:in `require'
/usr/share/redmine/lib/plugins/acts_as_activity_provider/init.rb:2:in `block in <top (required)>'
/usr/share/redmine/config/initializers/00-core_plugins.rb:12:in `eval'
/usr/share/redmine/config/initializers/00-core_plugins.rb:12:in `block in <top (required)>'
/usr/share/redmine/config/initializers/00-core_plugins.rb:2:in `each'
/usr/share/redmine/config/initializers/00-core_plugins.rb:2:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:268:in `load'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:268:in `block in load'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/dependencies.rb:268:in `load'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:652:in `block in load_config_initializer'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/activesupport/lib/active_support/notifications.rb:166:in `instrument'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:651:in `load_config_initializer'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:616:in `block (2 levels) in <class:Engine>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:615:in `each'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/engine.rb:615:in `block in <class:Engine>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:30:in `instance_exec'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:30:in `run'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:55:in `block in run_initializers'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:44:in `each'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:44:in `tsort_each_child'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/initializable.rb:54:in `run_initializers'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:352:in `initialize!'
/usr/share/redmine/config/environment.rb:14:in `<top (required)>'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:328:in `require'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:328:in `require_environment!'
/var/lib/gems/2.3.0/bundler/gems/rails-f626b47d5606/railties/lib/rails/application.rb:457:in `block in run_tasks_blocks'
/var/lib/gems/2.3.0/gems/rake-12.0.0/exe/rake:27:in `<top (required)>'
/usr/local/bin/ruby_executable_hooks2.3:15:in `eval'
/usr/local/bin/ruby_executable_hooks2.3:15:in `<main>'
Tasks: TOP => redmine:plugins:migrate => environment
(See full trace by running task with --trace)

===================================

root@ubuntu:/usr/share/redmine/lib/plugins# apt-cache show redmine
Package: redmine
Priority: extra
Section: universe/web
Installed-Size: 8881
Maintainer: Ubuntu Developers <>
Original-Maintainer: Antonio Terceiro <>
Architecture: all
Version: 3.2.1-2
Depends: dbconfig-common, redmine-sqlite | redmine-mysql | redmine-pgsql, ruby | ruby-interpreter, ruby-actionpack-action-caching, ruby-actionpack-xml-parser, ruby-awesome-nested-set, ruby-bundler, ruby-coderay (>= 1.0.6), ruby-i18n (>= 0.6.9-1~), ruby-jquery-rails (>= 4.0.5), ruby-mime-types (>= 1.25), ruby-net-ldap (>= 0.3.1), ruby-openid, ruby-protected-attributes, ruby-rack (>= 1.4.5~), ruby-rack-openid, ruby-rails (>= 2:4.2.5), ruby-rails-observers, ruby-rbpdf, ruby-redcarpet, ruby-request-store, ruby-rmagick, ruby-roadie-rails, debconf (>= 0.5) | debconf-2.0
Pre-Depends: debconf
Recommends: passenger
Suggests: bzr, cvs, darcs, git, mercurial, ruby-fcgi, subversion
Breaks: redmine-plugin-botsfilter (<= 1.02-2), redmine-plugin-recaptcha (<= 0.1.0+git20121018)
Filename: pool/universe/r/redmine/redmine_3.2.1-2_all.deb
Size: 1100008
MD5sum: 248cbcfd69e3e1b67ec08f189b4c534c
SHA1: 507004a0b6dcf9cbc6ab22630114b0d7d473b928
SHA256: 1c809ab2adc59896ccd3ffbcfdeb72a5002d1008f2eabd7822ebf39593b5d369
Description-en: flexible project management web application
Redmine is a flexible project management web application. Written using Ruby
on Rails framework, it is cross-platform and cross-database.
.
Dependencies for database support are provided by these metapackages:
redmine-mysql, redmine-pgsql, redmine-sqlite.
.
Features * Multiple projects support * Flexible role based access control * Flexible issue tracking system * Gantt chart and calendar * News, documents & files management * Feeds & email notifications * Per project wiki * Per project forums * Time tracking * Custom fields for issues, time-entries, projects and users * SCM integration (SVN, CVS, Git, Mercurial, Bazaar and Darcs) * Issue creation via email * Multiple LDAP authentication support * User self-registration support * Multilanguage support
Description-md5: 3a216a1439e1b07aad3aecd0c613d53b
Homepage: http://www.redmine.org
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Gemfile.txt Magnifier (3.54 KB)