Upgrade Redmine 3.2.1 to 3.4.1

Added by Diego Gonzalez over 2 years ago

Good morning, I am a user and administrator of several years of Redmine, but this time it is complicating me to apply the update to 3.4.1. From what I've read, you have several better ones that would be useful to me when migrating from my 3.2.1, but I'm not doing it.

I followed the steps indicated in RedmineUpgrade however, in step "3.1.6 Install the required gems by running" is where I brake, when running the Command throws me the following error:

Gem :: Ext :: BuildError: ERROR: Failed to build gem native extension.

    Current directory: /var/lib/gems/2.3.0/gems/redcarpet-3.4.0/ext/redcarpet
/usr/bin/ruby2.3 -r ./siteconf20170712-38090-15wi6pm.rb extconf.rb
Mkmf.rb can not find header files for ruby ​​at /usr/lib/ruby/include/ruby.h

Extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.3.0/gems/redcarpet-3.4.0 for inspection.
Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/redcarpet-3.4.0/gem_make.out

An error occurred while installing redcarpet (3.4.0), and Bundler can not continue.
Make sure that `gem install redcarpet -v '3.4.0'` succeeds before bundling.

In Gemfile:
  Redcarpet

And I can not continue. I have searched and read trying to solve it without success, I work with a VM that I have restored more than once to try again and without success at the moment, that is why I request collaboration.

Thank you so much

Diego

Replies (9)

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Mischa The Evil over 2 years ago

Diego Gonzalez wrote:

Gem :: Ext :: BuildError: ERROR: Failed to build gem native extension.

    Current directory: /var/lib/gems/2.3.0/gems/redcarpet-3.4.0/ext/redcarpet
/usr/bin/ruby2.3 -r ./siteconf20170712-38090-15wi6pm.rb extconf.rb
Mkmf.rb can not find header files for ruby ​​at /usr/lib/ruby/include/ruby.h

Extconf failed, exit code 1

This error indicates that the Ruby development headers are required for the build of the Redcarpet gem but they cannot be found (they are either not installed or not in the path). Depending on your OS and the way Ruby is installed, you solve this by installing the Ruby development package(s) (usually ruby-dev or rubyx.x-dev) containing the required headers.

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Diego Gonzalez over 2 years ago

Thank you very much for your prompt response.
I do not want to abuse your time and generosity, but after doing what you told me, the problem that is presented to me is this:

Gem :: Ext :: BuildError: ERROR: Failed to build gem native extension.

    Current directory: /var/lib/gems/2.3.0/gems/redcarpet-3.4.0/ext/redcarpet
/usr/bin/ruby2.3 -r ./siteconf20170712-40305-1vlkqm8.rb extconf.rb
Creating Makefile

Current directory: /var/lib/gems/2.3.0/gems/redcarpet-3.4.0/ext/redcarpet
Make "DESTDIR =" clean
Sh: 1: make: not found

Current directory: /var/lib/gems/2.3.0/gems/redcarpet-3.4.0/ext/redcarpet
Make "DESTDIR =" 
Sh: 1: make: not found

Make failed, exit code 127

Gem files will remain installed in /var/lib/gems/2.3.0/gems/redcarpet-3.4.0 for inspection.
Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/redcarpet-3.4.0/gem_make.out

An error occurred while installing redcarpet (3.4.0), and Bundler can not continue.
Make sure that `gem install redcarpet -v '3.4.0'` succeeds before bundling.

In Gemfile:
  Redcarpet

My OS is Ubuntu 16.04 LTS \ n \ l

Thank you in advance.

Diego

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Diego Gonzalez over 2 years ago

Well, for the moment with:

1 - apt-get install build-essential

2 - apt-get install libmysqlclient-dev

I was able to complete this step, to arise some new problem I comment.

Thank you very much

Diego

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Diego Gonzalez over 2 years ago

Well, I've completed the steps listed at RedmineUpgrade

But when accessing via WEB, I continue accessing V3.2.1, which would subtract, where I indicate that it should be pointed to the new folder or is it that I have interpreted something else at the time of updating?

Thank you very much

Diego

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Pero Postar over 2 years ago

Diego Gonzalez wrote:

But when accessing via WEB, I continue accessing V3.2.1, which would subtract, where I indicate that it should be pointed to the new folder or is it that I have interpreted something else at the time of updating?

I'm having the exact same situation. I've done steps on UpgradeRedmine site.
@diego: did you manage to solve your problem?

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Diego Gonzalez over 2 years ago

I have not been able to solve it yet, I have tried different things, but without success

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Mischa The Evil over 2 years ago

It all depends on the way you've deployed Redmine in the first place. How is the Ruby interpreter installed (system package/RVM/etc.)? Which server (application/web/load-balancers/etc.) are you using? What integration mode are you using in case you use Phusion Passenger as a server? Etc.

Some example pointers for Phusion Passenger (as it is one of the most popular ways of deploying Rails applications in general):
  • if you were using it [integrated] as an Apache module, you'd have to edit the Apache configuration file to set the correct directory of the new Redmine release (see e.g. this passenger documentation).
  • if you were using it [integrated] as a Nginx module, you'd have to edit the Nginx configuration file to set the correct directory of the new Redmine release (see e.g. this passenger documentation).
  • OTOH, if you were using it stand-alone (started during system boot using a custom RC-file), you'd have to edit the RC-config file to match the new directory (see e.g. this passenger documentation).

We'd have to know the exact details of your Redmine deployment(s) before anyone here can give y'all more specific information on how to solve the given issue(s).

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Diego Gonzalez over 2 years ago

Many thanks Mischa The Evil, I am waiting for the administrator to restore the VM to retry the update, since I have tried the previous installation.
Once I have it I'll try what you tell me.
My installation on Ubuntu has been the default from the .tar file and for the little that I understand, it runs on apache.
I hope you know excuse my lack of precision, I am trying to learn and know more about Linux and Redmine.

Greetings.

Diego

RE: Upgrade Redmine 3.2.1 to 3.4.1 - Added by Diego Gonzalez over 2 years ago

I am more curious than studious, and therefore it is taking me longer than expected the update. I will not give up, but good that it would be simpler.
The most that I could approach was rename the folder redmine-3.4.2 by redmine and there I could see version 3.4.2, but many things do not work, for example when trying to access http: // redmine / settings
I get the error:

"Internal error

An error occurred on the page you were trying to access.
Please contact Redmine for assistance.

If you are the Redmine administrator, check your log files for details about the error.

Back "

Stay tuned to any comments.

Thank you very much.

Diego

(1-9/9)