can't start the redmine update

Added by John Doe about 1 month ago

When I do in console:
RAILS_ENV=production rake db:migrate
or:
rails
or:
gem

The answer is:
<internal:gem_prelude>:1:in `require': cannot load such file -- rubygems.rb (LoadError)
from <internal:gem_prelude>:1:in `<compiled>'
I don't know what to do, I did as most of topics says about completely deletion of ruby and a new installation, it didn't help. CentOS 6 is installed and I'm trying to launch an update of redmine.

Could someone help me?

Replies (4)

RE: can't start the redmine update - Added by Toshi MARUYAMA about 1 month ago

Try: RAILS_ENV=production bundle exec rake db:migrate

RE: can't start the redmine update - Added by Juan Diego Iannelli about 1 month ago

You could use this guide https://github.com/jiannelli/vagrant-redmine to install redmine on centos7 and then migrate the database.

RE: can't start the redmine update - Added by John Doe about 1 month ago

I don't think so, but thank you anyway.

(1-4/4)