Inline image

Added by Joc Joc 3 months ago

I have upgraded RedMine and CKeditor to last version. But now, the olds and news issues don't display the inline image.

For example :

blabla
!MyImage.png!
blabla

My file image haven't space into his name.

When I open an issue I see the text "!MyImage.png!" and not the real image.

Have you any ideas ?

Replies (6)

RE: Inline image - Added by Bernhard Rohloff 3 months ago

Perhaps you have selected markdown formatting in Redmine's main settings.
What does your headings look like?

Textile

h1. This is a textile heading
and this is an !image tag!

Markdown

# This is a markdown heading
and this is an ![](image_tag)

RE: Inline image - Added by Joc Joc 3 months ago

No, I use CKEditor and I check into general parameters and it is CKEditor selected.

RE: Inline image - Added by Bernhard Rohloff 3 months ago

Oh OK yes I somehow red over this. Sorry for that...
Was the text mentioned in your first post written with the CKEditor or did you switch zu CKEditor after time?
Because as far as i know, CKEditor creates HTML formatted pages with no textile or markdown parser involved at all. So all text you've written in textile before is just shown as plain text if you switch to CKEditor as the formatter afterwards.

RE: Inline image - Added by Joc Joc 3 months ago

Both of them.
I have olds issues that have been created with CKEditor 1.0.0
Before the update (redmine and CKEditor) the image with ! appares correctly on the issues.
So it is possible that this olds issues aren't work with the update.

But I have created new issues with the new CKEditor and even these don't appear with image.

RE: Inline image - Added by Bernhard Rohloff 3 months ago

So I've created a test instance with Redmine 3.4.4 and the latest CKEditor from the Github project.
What I can tell so far is that old images which where included with the !image! formatting are no longer shown after switching the formatting to CKEditor. Unfortunately the upload of images with CKEditor did not work at all in my test installation. So I was not able to test its specific behavior.

RE: Inline image - Added by Joc Joc 3 months ago

Thank for your help. I have uninstalled the CKEditor....

(1-6/6)