Error Default configuration data was not loaded.

Added by meria dlr over 1 year ago

Hi,
I try to install redmine 3.4.3 on Debian 9 Kimsufi server.
i follow this guide: https://www.supinfo.com/articles/single/6604-installer-configurer-redmine-debian-9

i have an error when i try to load default configuration.

commande

RAILS_ENV=production bundle exec rake redmine:load_default_data

Result:


Error: Mysql2::Error: Unknown column 'roles.builtin' in 'where clause': SELECT  1 AS one FROM `roles` WHERE `roles`.`builtin` = 0 LIMIT 1
Default configuration data was not loaded.

I have try this solution but she dont work for me: http://www.redmine.org/boards/2/topics/12279.
and i try this solution: http://www.redmine.org/boards/2/topics/52931
but i dont know how to unset shell envinronment variable $VERSION on debian.

Sorry i m not advanced user of debian

thx for your help

Replies (5)

RE: Error Default configuration data was not loaded. - Added by Bernhard Rohloff over 1 year ago

and i try this solution: http://www.redmine.org/boards/2/topics/52931
but i dont know how to unset shell envinronment variable $VERSION on debian.

You can easily unset the variable with the command

unset VERSION

RE: Error Default configuration data was not loaded. - Added by Jean Louis over 1 year ago

Hi,

I have the same problem on Debian 9.4, but my variable "VERSION" is not set.

what do you think of this stackoverflow question ? is it appropriate ?

Update: After investigations, the initial error (in step: rake db:migrate) that cause this problem seems to be in database initialization (see #23586 and issue #54308)

JL

RE: Error Default configuration data was not loaded. - Added by Martin Denizet (redmine.org team member) over 1 year ago

I get the error on Debian 9.4/MariaDB:

== 28 CreateWikiPages: migrating ==============================================
-- create_table(:wiki_pages)
   -> 0.0098s
-- add_index(:wiki_pages, [:wiki_id, :title], {:name=>:wiki_pages_wiki_id_title})
rake aborted!
StandardError: An error has occurred, all later migrations canceled:

Mysql2::Error: Specified key was too long; max key length is 767 bytes: CREATE  INDEX `wiki_pages_wiki_id_title`  ON `wiki_pages` (`wiki_id`, `title`)

Only if I create the database with:
CREATE DATABASE redmine CHARACTER SET utf8mb4;

It works fine if I create the database with:
CREATE DATABASE redmine CHARACTER SET utf8;

RE: Error Default configuration data was not loaded. - Added by Martin Denizet (redmine.org team member) over 1 year ago

This worked for me #23586-8 :
nano config/initializers/ar_innodb_row_format.rb

ActiveSupport.on_load :active_record do
    module ActiveRecord::ConnectionAdapters
        class AbstractMysqlAdapter
            def create_table_with_innodb_row_format(table_name, options = {})
                table_options = options.reverse_merge(:options => 'ENGINE=InnoDB ROW_FORMAT=DYNAMIC')
                create_table_without_innodb_row_format(table_name, table_options) do |td|
                    yield td if block_given?
                end
            end
            alias_method_chain :create_table, :innodb_row_format
        end
    end
end

Changed my.conf:

nano /etc/mysql/mariadb.conf.d/50-server.cnf

Adding to it:

innodb_large_prefix = 1
innodb_file_format = barracuda
innodb_file_per_table = 1

RE: Error Default configuration data was not loaded. - Added by Volk Theresa 10 months ago

I just found other way:

rake db:migrate RAILS_ENV=production

And it's work!

https://www.mobdro.guide/

(1-5/5)