Problem Upgrading to Version 4.0

Added by Studart Tavares 3 months ago

Hello,

I tried updating my Redmine from 3.4.6 to 4.0
I used the guide in http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade but I got an error when I tried to load the new version. The error was:

You have requested: nokogiri ~> 1.9.1 The bundle currently has nokogiri locked at 1.10.1. Try running `bundle update nokogiri` If you are updating multiple gems in your Gemfile at once, try passing them all to `bundle update` (Bundler::GemNotFound)
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/resolver.rb:286:in `block in verify_gemfile_dependencies_are_found!'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/resolver.rb:254:in `each'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/resolver.rb:254:in `verify_gemfile_dependencies_are_found!'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/resolver.rb:48:in `start'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/resolver.rb:22:in `resolve'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/definition.rb:258:in `resolve'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/definition.rb:171:in `specs'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/definition.rb:238:in `specs_for'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/definition.rb:227:in `requested_specs'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/runtime.rb:108:in `block in definition_method'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/runtime.rb:20:in `setup'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler.rb:107:in `setup'
/var/lib/gems/2.1.0/gems/bundler-1.16.5/lib/bundler/setup.rb:20:in `<top (required)>'
/usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:135:in `require'
/usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:135:in `rescue in require'
/usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:144:in `require'
/usr/lib/ruby/vendor_ruby/phusion_passenger/loader_shared_helpers.rb:263:in `block in run_load_path_setup_code'
/usr/lib/ruby/vendor_ruby/phusion_passenger/loader_shared_helpers.rb:366:in `running_bundler'
/usr/lib/ruby/vendor_ruby/phusion_passenger/loader_shared_helpers.rb:261:in `run_load_path_setup_code'
/usr/share/passenger/helper-scripts/rack-preloader.rb:100:in `preload_app'
/usr/share/passenger/helper-scripts/rack-preloader.rb:158:in `<module:App>'
/usr/share/passenger/helper-scripts/rack-preloader.rb:29:in `<module:PhusionPassenger>'
/usr/share/passenger/helper-scripts/rack-preloader.rb:28:in `<main>'

I'm using Debian 8 and Apache 2

Thanks in advance

Replies (1)

RE: Problem Upgrading to Version 4.0 - Added by Marius BALTEANU 3 months ago

If you run bundle update nokogiri what happens?

(1-1/1)