admin login doesn't bring me welcome page

Added by youngseok yi over 9 years ago

I want to use hostname to connect redmine on local network. (or active directory hostname)

When I login from http://localhost:3000 or http://ip-adress:3000, I can see the welcome page.
But when I tries to login from http://hostname:3000, login doesn't bring me to the welcome page.
It just shows login page again and there is no invalid user message.

my environment
  • OS - Windows XP
  • ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
  • rails-2.0.2
  • mongrel-1.1.3-i386-mswin32

if anyone knows the solution, please let me know.

Replies (5)

RE: admin login doesn't bring me welcome page - Added by Thomas Lecavelier over 9 years ago

Damn! Someone finally reproduce my quite old bug! Could you precise what browser you're using, IE I bet? :)

RE: RE: admin login doesn't bring me welcome page - Added by youngseok yi over 9 years ago

:) Yes. you won the wager. It is IE v6.
Currently, I'm out of the network, I have not yet tested with firefox or safari.
Let you know the result with the other browser. thanks.
  • redmine 0.6.4.

RE: admin login doesn't bring me welcome page - Added by Jean-Philippe Lang over 9 years ago

IE6 works fine for me.
There must be another reason, does your browser accept cookies ?

RE: RE: admin login doesn't bring me welcome page - Added by youngseok yi over 9 years ago

all of my browser accept cookies.
Only firefox allows me to login with hostname.
ie and safari shows same login page again.

firefox -> 2.0.0.13
ie -> 6.0.2900 SP2
safari 3.0.4 (523.15)

I've tried on the same host where redmine installed.

By the way, I've come to love ruby and ruby on rails.
I hope I would learn shiny ruby, and ror on my sparetime.

RE: RE: RE: admin login doesn't bring me welcome page - Added by youngseok yi over 9 years ago

here is stdout log on the command shell.
log with ie

Processing AccountController#login (for 10.168.50.157 at 2008-04-28 10:11:47) [POST]
  Session ID: b067dbf4d1ebdcf950b470e3f9793292
  Parameters: {"action"=>"login", "controller"=>"account", "password"=>"[FILTERED]", "login"=>"admin"}
Redirected to http://ys_yi:3000/my/page
Completed in 0.04000 (25 reqs/sec) | DB: 0.04000 (100%) | 302 Found [http://ys_yi/account/login]

Processing MyController#page (for 10.168.50.157 at 2008-04-28 10:11:47) [GET]
  Session ID: 121e03650aa199315f026ad09bde279f
  Parameters: {"action"=>"page", "controller"=>"my"}
Redirected to http://ys_yi:3000/account/login
Filter chain halted as [#<ActionController::Filters::ClassMethods::SymbolFilter:0x4851520 @filter=:check_if_login_required>] returned_false.
Completed in 0.01000 (100 reqs/sec) | DB: 0.00000 (0%) | 302 Found [http://ys_yi/my/page]

Processing AccountController#login (for 10.168.50.157 at 2008-04-28 10:11:47) [GET]
  Session ID: 59247b050f77c6cb0938a677a0f7e1bf
  Parameters: {"action"=>"login", "controller"=>"account"}
Rendering  within layouts/base
Rendering account/login
Completed in 0.01000 (100 reqs/sec) | Rendering: 0.01000 (100%) | DB: 0.00000 (0%) | 200 OK [http://ys_yi/account/login]

log with firefox

Processing AccountController#login (for 10.168.50.157 at 2008-04-28 10:12:44) [POST]
  Session ID: 1aefbe1120ef1b7624156a54435b802f
  Parameters: {"action"=>"login", "controller"=>"account", "password"=>"[FILTERED]", "login"=>"admin"}
Redirected to http://ys_yi:3000/
Completed in 0.03000 (33 reqs/sec) | DB: 0.02000 (66%) | 302 Found [http://ys_yi/account/login]

Processing WelcomeController#index (for 10.168.50.157 at 2008-04-28 10:12:44) [GET]
  Session ID: 1aefbe1120ef1b7624156a54435b802f
  Parameters: {"action"=>"index", "controller"=>"welcome"}
Rendering  within layouts/base
Rendering welcome/index
Completed in 0.04000 (25 reqs/sec) | Rendering: 0.02000 (50%) | DB: 0.02000 (50%) | 200 OK [http://ys_yi/]

(1-5/5)