Redmine extremely slow after upgrading to 0.7

Added by João Saleiro over 9 years ago

Hello,

some weeks ago I have updated my redmine installation to version 0.7RC1.
After the upgrade, redmine got extremely slow, taking almost one minute to go from one page to another. I waited to see if the 0.7 final version of redmine was also slow. Today I have upgraded to 0.7.1 but it didn't solved my problem - it's still very, very slow.

I know nothing about RoR (my experience with RoR is limited to install and upgrade redmine), so it's hard for me to track the problem.

Here is the output of my script/about :

Ruby version 1.8.5 (i386-linux)
RubyGems version 0.9.2
Rails version 2.0.2
Active Record version 2.0.2
Action Pack version 2.0.2
Active Resource version 2.0.2
Action Mailer version 2.0.2
Active Support version 2.0.2
Edge Rails revision rel_2-0-2
Application root /home/webadmin/webfuel.pt/html/gestor
Environment development
Database adapter mysql
Database schema version 92

Can you help?

Thank you in advance for your help, and thank you for the best project management tool ever done!

João Saleiro

Replies (1)

RE: Redmine extremely slow after upgrading to 0.7 - Added by Adam Knight over 9 years ago

You need to research installing FastCGI on your webserver. Without that, Ruby is starting up, compiling the source, and then executing it for every request to the webserver. With FastCGI, it runs one instance of Ruby and keeps everything in memory for an extremely quick response time.

(1-1/1)