Repository doesn't work with redmine

Added by Stefano A. about 10 years ago

Hi all, i have a very big problem. I'm running redmine 0.8.4 on windows server and visualsvn on the same machine. Svn repository it's ok and when i try to access it from browser or typing in cmd svn list But i can't access it from redmine. I found this old topic but the man didn't explain how he solved. Please help me!

LINK

Replies (11)

RE: Repository doesn't work with redmine - Added by Stefano A. about 10 years ago

please any idea? it's urgent

RE: Repository doesn't work with redmine - Added by Benedikt Niessen about 10 years ago

Hi Stefano,

Sorry, Im experienced in running Redmine on a Windows machine, but when I installed Redmine the first time on my BSD-Server I had the same problem. I was missing the SVN-binaries in the PATH.

Maybe you can check here and also you should analyze your logfiles. The information you give us here is quite close to zero.

- What do the logs say?
- What "does not work"? Is it just the listing? Error message? It appears nothing? What is it?

So please provide some more information.

RE: Repository doesn't work with redmine - Added by Stefano A. about 10 years ago

the error is:

An error occurred when trying to access the repository: No such file or directory - svn list --xml "https://[myserver]:8443/[REPOSITORY PATH]/"@HEAD --username xxxx --password xxxx

and i can't access repository from redmine. If i try to access the repository with browser it's ok, if i try with cmd too

RE: Repository doesn't work with redmine - Added by Benedikt Niessen about 10 years ago

The error is written. Svn is not found, see my prev. Post.

RE: Repository doesn't work with redmine - Added by Stefano A. about 10 years ago

problem solved, on my win server 2008 there wasn't in the PATH list the svn... thank to all

RE: Repository doesn't work with redmine - Added by Kondi Kondi almost 10 years ago

Can you tell me what do you do exactly to enable repo in redmine ?

RE: Repository doesn't work with redmine - Added by Stefano A. almost 10 years ago

i installed on the server (windows) visualsvn and i put the url in redmine config

RE: Repository doesn't work with redmine - Added by Benedikt Niessen almost 10 years ago

You want to do the config or you have an error message and want to fix it?

You are not precise enough. Basically everything is written in the documentation or within this thread.

Good luck.

RE: Repository doesn't work with redmine - Added by Kondi Kondi almost 10 years ago

i do that:

Redmine on iis 7.5 (FastCGIModule)
install visualsvn on http://server:8080/projects
config redmine project on the tab repository:
URL: http://server:8080/projects
login and password
run in command line: ruby script/runner "Repository.fetch_changesets" -e production

and still have error:
"The entry or revision was not found in the repository."

Benedikt Niessen. in documentation is only [[http://www.redmine.org/wiki/redmine/RedmineRepositories]] - the same steps i already done

Maybe in Redmine.pm or reposman.rb i must change something ?

RE: Repository doesn't work with redmine - Added by Stefano A. almost 10 years ago

mmmm i had the same problem, try to add in visualsvn an user with read permissions, after that setup redmine to use that user

RE: Repository doesn't work with redmine - Added by Kondi Kondi almost 10 years ago

User have full permission to that repo

I try the same steps on webrick server and the same error...

What the f... !!!

(1-11/11)