Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste)

Added by Chris McKee over 7 years ago

Has anyone managed to install http://www.redmine.org/wiki/redmine/PluginScreenshotPaste on 0.9.1+ ?

I get errors when I try to rake update.

Replies (12)

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Matt Hamilton over 7 years ago

I have just installed the 1.1.0 on the trunk r3739, don't appear to have problem any running rake update but can't get the plugin to save any screen shots.

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Chris McKee over 7 years ago

ill have to test it on a clean build later it may be a conflict though i cant see what could conflict with such a small plugin humping along a pile of java.

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Konstantin Zaitsev over 7 years ago

Chris McKee wrote:

ill have to test it on a clean build later it may be a conflict though i cant see what could conflict with such a small plugin humping along a pile of java.

You can try the following alternatives http://www.redmine.org/attachments/3707/redmine_attach_screenshot_v.0.0.3.zip

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Chris McKee over 7 years ago

That one seems to work right up to the applet kicking in and clicking save; probably a bit overkill in the long run as most of our UAT team seem happy with dumping screenshots into word (God knows why).

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Anonymous over 7 years ago

I haven't been able to get the 0.2 version working with Redmine 0.9.5. My company's thinking of switching to Redmine, but my manager really wants to be able to paste screenshots easily, so this is a high priority for me.

I've found and fixed two problems:

  1. The applet tag in the HTML file seems to be wrong, or at least doesn't work with Chrome, so the applet wouldn't load at all. Adding a 'codebase' attribute and making the 'archive' and 'code' URLs relative to it made the applet load. I've attached the file.
  2. The plugin directory has to be renamed to just "redmine_screenshot_paste", removing the version number from the end, or the URL to the applet won't work.

Even with that, when I submit the form the attachment never gets added. Looking at the server log, I can see it appearing in the parameters for the IssueController#edit submission:
"uploaded_screenshot"=>{"name"=>"screenshot", "content"=>"............"}
with a big glob of what looks like base64 data. But the logs don't show any inserts being made to the attachment table. No errors/exceptions, though.

Any ideas?

_screenshot.rhtml Magnifier (934 Bytes)

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Anonymous over 7 years ago

I've now also tried out the redmine_attach_screenshot_v.0.0.3 mentioned above. Its applet loads fine out of the box, but again the attachment never gets added to the database. No errors or exceptions in the log.

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Billy T over 7 years ago

I have 1.1 installed on Redmine trunk.
It works perfectly if java installed. Does it use Java?

confused

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Anonymous over 7 years ago

The client side is working fine for me; the applet runs and the image data gets submitted in the POST.
It's the server side that isn't working right.
Maybe the difference is that you're on trunk while I'm on 0.9.5?

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Bart Stuyckens about 7 years ago

I have tried the version 1.1 on Redmine 1.0. The plugin works, but screenshots do not get attached.

related to http://www.redmine.org/boards/3/topics/16088?r=16611

RE: Redmine Screenshot Paste (http://www.redmine.org/wiki/redmine/PluginScreenshotPaste) - Added by Mark Linn about 7 years ago

I have 1.1. working on Redmine 1.0 and seems to work fine in IE, but, in Linux Firefox or Chromium the browser displays the applet just fine and allows me to attach, but, when I submit the server logs show that the content is coming in nil instead of the long base64 encoded string I see when I submit with IE.

I tried the redmine_screenshot_attach plugin also and see basically the exact same results. Could it be maybe security settings in the browser or something. I have a basic Ubuntu 10.04 install with no mods to the security settings of Firefox.

Add redmine_attach_screenshot plugin - Added by Ginisleisy Morales almost 7 years ago

I have installed redmine in a sub-URI on Windows with Apache including the additional components (RMagic and redmine_attach_screenshot plugin) but it doesn't have the expected effect. I mean, the localhost/redmine doesn't show the screens of redmine.

What should I do?

(1-12/12)