Migrating ckeditor wysywig editor to the 1.0 release.

Added by Todd Nine about 9 years ago

Hey guys,
We're trying to get everyone at work onto redmine including the sales staff. Our biggest obstacle is that google Docs is easy to use, and I've been tasked with installing a wysiwyg editor. I've found this one, which appears to be the most promising.

http://github.com/tnine/redmine_ckeditor/

However, it's built for 0.9. The "render" method in the issues controller has been removed, so the plugin no longer works. This file attempts to process the output from the IssueController.

http://github.com/tnine/redmine_ckeditor/blob/master/lib/redmine_ckeditor/issues_controller_patch.rb

Can anyone give me some guidance on how to go about fixing this to be compatible with the 1.0 release? I use ruby a lot for chef recipes, but I haven't done a lot of rails development.

Thanks,
Todd

Replies (3)

(1-3/3)