404 plugin_assets

Added by Matt Cheung about 6 years ago

Hi Everyone,

I know there are other posts that sound similar to this one:

http://www.redmine.org/boards/3/topics/16126

However, I don't believe I'm having the wrong subURI issue with the plugin_assets generated by rails. I am currently running Redmine 0.9.3.stable on Ubuntu 10.04 and Apache and have installed the redmine-hudson plugin which is working except it isn't serving up the assets and I get 404 errors when trying to go to access any links to http://DOMAIN/redmine/plugin_assets/*. The plugin_assets are located in 2 locations on my server:

My plugin install directory - /usr/share/redmine/vendor/plugins/redmine_hudson/assets
Generated by Apache and owned by www-data? - /var/cache/redmine/default/plugin_assets/redmine_hudson

It seems like Apache is finding the assets and putting it somewhere, but I can't find the location of the assets if they are available at all or the reason why they are missing.

From looking at the page source the plugin is trying to get its assets from:

http://DOMAIN/redmine/plugin_assets/redmine_hudson/*
with
http://DOMAIN/redmine being redmine home which looks right to me.

Any help would be greatly appreciated.

Replies (5)

RE: 404 plugin_assets - Added by Brad Neuman about 6 years ago

I am also still having this problem on ubuntu 10.04 with redmine 1.2.1.stable. I have followed every forum and wiki page I could find about setting up my sub-uri ("/redmine"), but nothing I have tried has solved the plugin_assets error.

Everything else works, but the html page requests /redmine/plugin_assets/ but I get 404 errors and errors in my redmine production log like:

ActionController::RoutingError (No route matches "/plugin_assets/redmine_git_hosting/images/paste.png" with {:method=>:get}):

This happens with multiple plugins.

This problem is currently the bottleneck in my groups website deployment and is holding back several other projects, so any help would be greatly appreciated by me as well.

RE: 404 plugin_assets - Added by Brad Neuman about 6 years ago

I hacked this into working by manually creating a folder 'public/plugin_assets' and copying over everything manually, e.g.

cp -r vendor/plugins/plugin_name/assets public/plugin_assets/plugin_name

This is not a good fix, though, because if I upgrade anything or install new plugins, I'll have to manually delete this folder and do this again.

RE: 404 plugin_assets - Added by Niclas Niclas Roßberger about 6 years ago

I had the same problem on Ubuntu 10.10 Server.
To fix this you just have to make the following symbolic link in the "public" folder (and set permissions):
ln -s /var/cache/redmine/default/plugin_assets

RE: 404 plugin_assets - Added by Ruben Barkow about 3 years ago

I had the same problem, and i found out, that it was a missing directory block in my apache, I added this in

/etc/apache2/sites-enabled/001-redmine.conf

I added this:

    Alias "/plugin_assets/" /var/cache/redmine/default/plugin_assets/
    <Directory "/var/cache/redmine/default/plugin_assets">
        Allow from all
        Options -MultiViews
        Require all granted
    </Directory>

restart apache and it should work

RE: 404 plugin_assets - Added by Aleksandar Pavic visit redminecookbook.com 9 months ago

I can confirm it works with newest ubuntu default installation,

I just changed /var/cache to /usr/share/redmine/public/plugin_assets

(1-5/5)