Smart issues sort plugin

Added by Vitaly Klimov almost 6 years ago

Intro

  • Plugin replaces default Redmine issues sorting with one more intellegent. This type of sorting always puts children issues of parent issue after parent.
  • Also plugin eleminates inconvenience when root issues sorted by parent issue are sorted by their ids instead.
  • Plugin adds categories support for Redmine queries and displays queries grouped by categories.
  • Plugin adds new option to queries which allows to always sort query by parent first thus keeping hierarchical issues structure

For details please visit plugin page

Up to date plugin page

http://www.redmine.org/plugins/redmine_smart_issues_sort

Replies (55)

RE: Smart issues sort plugin - Added by Andrew Hackley about 3 years ago

Muditha,
I just installed the plugin on redmine 2.4.5 and received the same error. I think it's due to the "views revisions" plugin (http://www.redmine.org/plugins/redmine_plugin_views_revisions) not working correctly. I was able to fix the issue by replacing:
redmine_smart_issues_sort/app/views/queries/_form.html.erb
with:
redmine_smart_issues_sort/rev/app/views/queries/2.3.2-_form.html.erb

Hope that helps!

RE: Smart issues sort plugin - Added by Massimo Rossello about 3 years ago

@Muditha, @Andrew, have you run "rake redmine:plugins:process_version_change"?
This is required by views_revisions plugin in order to do automatically the substitution you made manually

RE: Smart issues sort plugin - Added by Muditha Jayawardana about 3 years ago

Hi Andrew,

Your fix is worked for me.
Thank you very much.

RE: Smart issues sort plugin - Added by li an about 3 years ago

Hi,

I found a bug, the feature is ok, but redmine custom qurey cannot be edit if I installed this plug-in, redmine provides custom query, I set some querys for projects to export different types of issue, but when I installed this plug-in, if I want to edit the customized query, there is error shown. Can it be fixed?

Thanks.

RE: Smart issues sort plugin - Added by Bryan Casano over 2 years ago

Hi,

I'm trying to install this plugin and I got this error when I ran rake redmine:plugins:process_version_change RAILS_ENV=production.

This is my error:

rake aborted!
NameError: undefined method `issues' for class `Query'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/core_ext/module/aliasing.rb:31:in `alias_method'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/core_ext/module/aliasing.rb:31:in `alias_method_chain'
/usr/share/redmine/plugins/redmine_smart_issues_sort/lib/query_patch.rb:12:in `block in included'
/usr/share/redmine/plugins/redmine_smart_issues_sort/lib/query_patch.rb:10:in `class_eval'
/usr/share/redmine/plugins/redmine_smart_issues_sort/lib/query_patch.rb:10:in `included'
/usr/share/redmine/plugins/redmine_smart_issues_sort/lib/query_patch.rb:98:in `include'
/usr/share/redmine/plugins/redmine_smart_issues_sort/lib/query_patch.rb:98:in `<top (required)>'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:251:in `block in require'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:236:in `load_dependency'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:251:in `require'
/usr/share/redmine/plugins/redmine_smart_issues_sort/init.rb:25:in `block in <top (required)>'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/callbacks.rb:440:in `_run__789215630__prepare__760423480__callbacks'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/callbacks.rb:405:in `__run_callback'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/callbacks.rb:385:in `_run_prepare_callbacks'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/callbacks.rb:81:in `run_callbacks'
/var/lib/gems/1.9.1/gems/actionpack-3.2.19/lib/action_dispatch/middleware/reloader.rb:74:in `prepare!'
/var/lib/gems/1.9.1/gems/actionpack-3.2.19/lib/action_dispatch/middleware/reloader.rb:48:in `prepare!'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/application/finisher.rb:47:in `block in <module:Finisher>'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/initializable.rb:30:in `instance_exec'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/initializable.rb:30:in `run'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/initializable.rb:55:in `block in run_initializers'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/initializable.rb:54:in `each'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/initializable.rb:54:in `run_initializers'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/application.rb:136:in `initialize!'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/railtie/configurable.rb:30:in `method_missing'
/usr/share/redmine/config/environment.rb:14:in `<top (required)>'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:251:in `block in require'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:236:in `load_dependency'
/var/lib/gems/1.9.1/gems/activesupport-3.2.19/lib/active_support/dependencies.rb:251:in `require'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/application.rb:103:in `require_environment!'
/var/lib/gems/1.9.1/gems/railties-3.2.19/lib/rails/application.rb:305:in `block (2 levels) in initialize_tasks'
Tasks: TOP => redmine:plugins:process_version_change => environment
(See full trace by running task with --trace)

Can someone help me? And also, I am on a redmine 2.6.0stable already.

Thank you!

1 2 3 (51-55/55)