redmine_meeting plugin / asking for enhancements in email content

Added by Richard Rauch about 4 years ago

Hi,
we have installed the redmine_meeting plugin. it is amazing and increases the usability of our project management.

we have some issues for the email notification, which is sent to the participants. maybe somebody has solved already or have good ideas, how to do this.

1. adding a link to the email content, which links directely to the meeting issue

like: http://my-redmine-server-address/projects/my-project/meetings/show_meeting?id=4

2. send the attachments, which are attached to the meeting, with the notification email (maybe with additional checkbox)

If there is not already a solution, we will try to solve by ourself. But any hints, how to do, are welcome!

Thanks
Richard

Replies (10)

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Arnaud Martel about 4 years ago

Hi,
Happy to see that you're using my plugin! Regarding the 2 features you are asking for, the first one is a very good suggestion and it should be easy to implement (I will try to add it next week). The other one is a little more difficult because I should deal with the size of the generated email to be sure that it will be accepted by all mail servers and will not fill mailboxes. Today, I don't have found an ideal solution but maybe in the future...

Kind regards,
Arnaud

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Richard Rauch about 4 years ago

Hi,
right now I updated with new plugin version. It works exactely as expected.
I have now a link to meeting inside the email notification, which is an advantage for all meeting participants!
Many thanks for providing maintenance!

Richard

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Youssef Boujraf almost 4 years ago

Dear,

I am just installed the new bitnami package :

Environment:
Redmine version 2.4.1.stable
Ruby version 1.9.3-p231 (2012-05-25) [i386-mingw32]
Rails version 3.2.16
Environment production
Database adapter Mysql2

And the redmine_meeting plugin doesn't work anymore.

Started GET "/redmine/projects/rfiautomation/meetings/index" for xxx.xxx.xxx.xxx at 2013-12-10 03:08:25 +0100

LoadError (cannot load such file -- ri_cal):
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `require'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `block in require'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:236:in `load_dependency'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `require'
  plugins/redmine_meetings/app/controllers/meetings_controller.rb:9:in `<top (required)>'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `require'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `block in require'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:236:in `load_dependency'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `require'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:359:in `require_or_load'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:502:in `load_missing_constant'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:192:in `block in const_missing'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:190:in `each'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:190:in `const_missing'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/inflector/methods.rb:230:in `block in constantize'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/inflector/methods.rb:229:in `each'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/inflector/methods.rb:229:in `constantize'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:554:in `get'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/routing/route_set.rb:69:in `controller_reference'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/routing/route_set.rb:54:in `controller'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/routing/route_set.rb:32:in `call'
  vendor/bundle/ruby/1.9.1/gems/journey-1.0.4/lib/journey/router.rb:68:in `block in call'
  vendor/bundle/ruby/1.9.1/gems/journey-1.0.4/lib/journey/router.rb:56:in `each'
  vendor/bundle/ruby/1.9.1/gems/journey-1.0.4/lib/journey/router.rb:56:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/routing/route_set.rb:608:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-openid-1.3.1/lib/rack/openid.rb:98:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/etag.rb:23:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/conditionalget.rb:25:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/head.rb:14:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/params_parser.rb:21:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/flash.rb:242:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:210:in `context'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:205:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/cookies.rb:341:in `call'
  vendor/bundle/ruby/1.9.1/gems/activerecord-3.2.16/lib/active_record/query_cache.rb:64:in `call'
  vendor/bundle/ruby/1.9.1/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:479:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/callbacks.rb:405:in `_run__566138017__call__374120006__callbacks'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/callbacks.rb:405:in `__run_callback'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/callbacks.rb:385:in `_run_call_callbacks'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/callbacks.rb:81:in `run_callbacks'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/callbacks.rb:27:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/remote_ip.rb:31:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
  vendor/bundle/ruby/1.9.1/gems/railties-3.2.16/lib/rails/rack/logger.rb:32:in `call_app'
  vendor/bundle/ruby/1.9.1/gems/railties-3.2.16/lib/rails/rack/logger.rb:16:in `block in call'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/tagged_logging.rb:22:in `tagged'
  vendor/bundle/ruby/1.9.1/gems/railties-3.2.16/lib/rails/rack/logger.rb:16:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/request_id.rb:22:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/methodoverride.rb:21:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/runtime.rb:17:in `call'
  vendor/bundle/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/cache/strategy/local_cache.rb:72:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/lock.rb:15:in `call'
  vendor/bundle/ruby/1.9.1/gems/actionpack-3.2.16/lib/action_dispatch/middleware/static.rb:63:in `call'
  vendor/bundle/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'
  vendor/bundle/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:245:in `fetch'
  vendor/bundle/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:185:in `lookup'
  vendor/bundle/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:66:in `call!'
  vendor/bundle/ruby/1.9.1/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'
  vendor/bundle/ruby/1.9.1/gems/railties-3.2.16/lib/rails/engine.rb:484:in `call'
  vendor/bundle/ruby/1.9.1/gems/railties-3.2.16/lib/rails/application.rb:231:in `call'
  vendor/bundle/ruby/1.9.1/gems/railties-3.2.16/lib/rails/railtie/configurable.rb:30:in `method_missing'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/urlmap.rb:64:in `block in call'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/urlmap.rb:49:in `each'
  vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/urlmap.rb:49:in `call'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/connection.rb:80:in `block in pre_process'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/connection.rb:78:in `catch'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/connection.rb:78:in `pre_process'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/connection.rb:53:in `process'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/connection.rb:38:in `receive_data'
  vendor/bundle/ruby/1.9.1/gems/eventmachine-1.0.3-x86-mingw32/lib/eventmachine.rb:187:in `run_machine'
  vendor/bundle/ruby/1.9.1/gems/eventmachine-1.0.3-x86-mingw32/lib/eventmachine.rb:187:in `run'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/backends/base.rb:61:in `start'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/server.rb:159:in `start'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/controllers/controller.rb:86:in `start'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/runner.rb:185:in `run_command'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/lib/thin/runner.rb:151:in `run!'
  vendor/bundle/ruby/1.9.1/gems/thin-1.3.1-x86-mingw32/bin/thin:6:in `<top (required)>'
  bin/thin:16:in `load'
  bin/thin:16:in `<main>'

May I ask you to tell me if this is a problem with the Ruby version or the plugin isn't supported with Ruby V1.9.3?
I tried to update the RI_CAL but still in version :

C:\BitNami\apps\redmine\htdocs\plugins>gem install ri_cal
Successfully installed ri_cal-0.8.8
Parsing documentation for ri_cal-0.8.8
Done installing documentation for ri_cal after 3 seconds
1 gem installed

I wont to loose my database with all meeting alreday created.

Best Regards,
Youssef

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Arnaud Martel almost 4 years ago

Hi Youssef,

I'm sorry but I don't use BitNami and I can't reproduce your error. Maybe you should update your gems using bundler (and not gem install ri_cal from the plugins directory)...
Anyway, I don't think you have lost your existing meetings and I'm pretty sure that your database is OK.

For information, here is my configuration (and I don't have any trouble with my plugin):

Environment:
  Redmine version                2.4.1.stable
  Ruby version                   1.9.3-p362 (2012-12-25) [i686-linux]
  Rails version                  3.2.16
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.7.3
  Git                            1.7.4.1
  Filesystem
Redmine plugins:
  ezfaq_plugin                   0.1.9
  login_attempt_limiter          0.0.1
  redmine_bioproj                0.0.4
  redmine_graphs                 0.1.0
  redmine_http_auth              0.3.0-dev
  redmine_meetings               0.2.4
  redmine_mylyn_connector        2.8.2.stable
  redmine_neurospin              0.0.1
  redmine_openbbb                trunk
  redmine_pdf_wiki               0.0.4
  redmine_publishing             0.0.1
  redmine_scm_create             0.0.2
  redmine_scm_extensions         0.4.0
  redmine_synapse                0.0.2
  redmine_watchers_customfield   0.0.1
  redmine_webdav                 0.6.0
  redmine_wiki_extensions        0.3.1
  redmine_xapian                 2.0.0
  send_email                     0.1.0
  system_notification            0.1.0a

Kind regards,
Arnaud

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Richard Rauch almost 4 years ago

Hi,

for your information: My Installation is based on current version of Bitnami installer, too (Im using Windows, not Linux).
On my installation the meeting plugin is working fine.
So I do not think, that your problem is anyhow related to Bitnami specific stuff!

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Youssef Boujraf almost 4 years ago

Dear,

Me too I am using bitnami with windows.

I am trying to reinstall the Bitnami Rubystack and the Redmine 2.4.1-1 module.

I will let you know when installed.

Best Regards,
Youssef

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Youssef Boujraf almost 4 years ago

Dear Richard,

May I ask you to send me the link to download the correct link for bitnami install.

Unfortunatly, I get the same error after installing the Bitnami rubystack and Redmine.

After checking, in the Ruby folder, I get a folder named 'Ruby 1.9.1' instead of 'Ruby 1.9.3'

Thanks a lot

Youssef

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Richard Rauch almost 4 years ago

Hi,
I checked now in detail.
seems I was wrong! I checked my installed version. I am installed exactely with this installer: bitnami-redmine-2.3.3-1-windows-installer.exe,
which I have downloaded from here: http://bitnami.com/stack/redmine

so I am using a bit older version than you. (I installed in September)
I have not tested with newest version. Seems there are updates from Bitnami at least monthly :(

In general it works with Bitnami, but I do not know if it works with newest version 2.4.x

RE: redmine_meeting plugin / asking for enhancements in email content - Added by Youssef Boujraf almost 4 years ago

Dear,

I fixed the issue :

http://community.bitnami.com/t/redmine-2-4-1-plugin-installation-error/21962/4

$ bundle install --without development test postgresql sqlite --no-deployment
$ bundle install --without development test postgresql sqlite --deployment
$ bin/rake redmine:plugins:migrate RAILS_ENV=production

Best Regards,
Youssef

(1-10/10)