amartel/redmine_meetings: Not working with Redmine 2.5

Added by Dustin Peterson over 5 years ago

Hello,

in Redmine 2.3 I was using the meetings plugin from Arnaud Martel: https://github.com/amartel/redmine_meetings
Unfortunately, this plugin is not working anymore since version 2.4 of Redmine:
If I try to create a new meeting, filling the form's fields and click on "Create", I will be redirected to the form again and no meeting has been created.

I was trying to get a hint, what's the issue, but I cannot find an answer in the logs. Everything seems to work fine.

Can anybody help me with this issue?

Thanks in advance!
Dustin

Replies (7)

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Arnaud Martel over 5 years ago

Hello Dustin,

I think that you may not use a correct version of my plugin as I have defined 3 branches on the github repository:
- master branch is to be used with redmine 2.5.0 and up (I use it with redmine 2.5.0 and 2.5.1)
- redmine_1.4 and redmine_1.2 branches were created for previous versions of redmine

I apologize for my poor documentation as these 3 different versions/branches are not clearly explained but are you sure to use the good version of my plugin?
If yes, could you give more information (especially, an extract of your production.log file will be very helpful and the result of "ruby script/about" too)?

Kind regards,
Arnaud

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Dustin Peterson over 5 years ago

Hello Arnaud,

thanks a lot for your quick answer!

Yes, I am using the master branch (especially checked out this branch again, there's no change in the plugin's behavior).

Here is an extract from production.log (Click on "Create Meeting", fill in the form, click on the send button):


Started GET "/redmine/projects/tstproject/meetings/new_meeting" for 84.130.180.207 at 2014-04-30 23:13:57 +0200
Processing by MeetingsController#new_meeting as HTML
Parameters: {"project_id"=>"tstproject"}
Current user: peterson (id=1)
Rendered attachments/_form.html.erb (14.0ms)
Rendered plugins/redmine_meetings/app/views/meetings/_form_meeting.html.erb (79.8ms)
Rendered plugins/redmine_meetings/app/views/meetings/new_meeting.html.erb within layouts/base (97.8ms)
Rendered plugins/a_common_libs/app/views/hooks/a_common_libs/_html_head.html.erb (3.5ms)
Rendered plugins/redmine_code_review/app/views/code_review/_html_header.html.erb (2.5ms)
Rendered inline template (1.3ms)
Rendered plugins/redmine_code_review/app/views/code_review/_body_bottom.html.erb (0.2ms)
Completed 200 OK in 425.7ms (Views: 326.5ms | ActiveRecord: 10.4ms)
Started POST "/redmine/projects/tstproject/meetings/create_meeting" for 84.130.180.207 at 2014-04-30 23:14:11 +0200
Processing by MeetingsController#create_meeting as HTML
Parameters: {"utf8"=>"✓", "authenticity_token"=>"lfCv0qlUYppgW00/ssupVjuXLN7Nwf4+YFeHdscOnzI=", "meeting"=>{"subject"=>"Test", "location"=>"test1", "start_date_date"=>"2014-04-30", "end_date_date"=>"2014-04-30", "description"=>"", "notify_participants"=>"on"}, "start_time"=>{"year"=>"2014", "month"=>"4", "day"=>"30", "hour"=>"23", "minute"=>"00"}, "end_time"=>{"year"=>"2014", "month"=>"5", "day"=>"1", "hour"=>"00", "minute"=>"00"}, "watchers"=>["1"], "commit"=>"Anlegen", "project_id"=>"tstproject"}
Current user: peterson (id=1)
Rendered attachments/_form.html.erb (5.7ms)
Rendered plugins/redmine_meetings/app/views/meetings/_form_meeting.html.erb (48.1ms)
Rendered plugins/redmine_meetings/app/views/meetings/new_meeting.html.erb within layouts/base (56.4ms)
Rendered plugins/a_common_libs/app/views/hooks/a_common_libs/_html_head.html.erb (6.0ms)
Rendered plugins/redmine_code_review/app/views/code_review/_html_header.html.erb (3.4ms)
Rendered inline template (2.0ms)
Rendered plugins/redmine_code_review/app/views/code_review/_body_bottom.html.erb (0.3ms)
Completed 200 OK in 328.5ms (Views: 161.2ms | ActiveRecord: 77.8ms)

The second HTTP request forces rendering of the Create Meeting-form again, unfortunately. (And no database entry will be created.)

Here's the content of script/about:

@
#!/usr/bin/env ruby

ENV["RAILS_ENV"] ||= "production"
require File.expand_path(File.dirname(FILE) + "/../config/environment")
puts
puts Redmine::Info.environment
@

In both files, I cannot get a clue why the wrong behavior is happening.
My redmine version is 2.5.0 (sorry, forgot to mention that).

Best Regards
Dustin

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Arnaud Martel over 5 years ago

Dustin,

About your environment, I needed the result of the command "ruby script/about" from the redmine directory (and not the content of the file ;) ).
Anyway, I don't understand what happens (your log seems to be OK) but I noticed that you use some others plugins (at least redmine_code_review and a_common_libs). Just to be sure, is it possible for you to move them outside the redmine/plugins directory, restart your web server and test if it solves the problem?

Kind regards,
Arnaud

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Dustin Peterson over 5 years ago

Hello Arnaud,

sorry - got the script/about thing wrong. ;)

I removed 2 plugins a step and found out, that your meetings plugin is working in 2.5 after disabling one of the following plugins:

  • redmine_monitoring_controlling
  • line_numbers

So, either monitoring_controlling or line_numbers has a conflict with your plugin.

Summarized: The meetings plugin is working fine now and I have to thank you a lot!

Best Regards
Dustin

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Mike Frelek over 1 year ago

Hello Arnaud,

I would like to use your plugin with the BBB meetings server.
It's about 4 years since the last post on this forum and I suppose the plugin was no more developed.
I tried to install this plugin on Redmine version 3.4.6 but with no luck.

Best Regards,
Mike

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Mike Frelek over 1 year ago

Hello Arnaud,

continuing the previous post:

I am not a rr developer so I cannot correct this error by myself.
If you are still there can you please make the plugin working with the current RM version? I will be grateful.
My Environment:
Redmine version 3.4.6.stable
Ruby version 2.3.7-p456 (2018-03-28) [x86_64-linux]
Rails version 4.2.8
Environment production
Database adapter Mysql2

Best Regards,
Mike

RE: amartel/redmine_meetings: Not working with Redmine 2.5 - Added by Mike Frelek over 1 year ago

See the attachement with the rake command error.

(1-7/7)