Install errors with Questions plugin

Added by Don Caprio over 8 years ago

I'm trying to install the questions plugin to my existing redmine 0.8.3-0.
I get the following error when doing the data base migration:

root# rake db:migrate_plugins RAILS_ENV=production
(in /srv/redmine-0.8.3-0/apps/redmine/vendor/plugins/question_plugin)
rake aborted!
Could not find RubyGem rspec (>= 0)
/srv/redmine-0.8.3-0/apps/redmine/vendor/plugins/question_plugin/Rakefile:4
(See full trace by running task with --trace)

I don't see any rspec files in any of the /srv/redmine-0.8.3-0 directories.
Does anyone have any clues what I'm doing wrong or whats missing?

Thank you.

My PATH is set to: /srv/redmine-0.8.3-0/ruby/bin
OS: Ubuntu 2.6.27-7-server
root# /srv/redmine-0.8.3-0/apps/redmine/script/about

About your application's environment
Ruby version              1.8.6 (i686-linux)
RubyGems version          1.0.1
Rails version             2.1.2
Active Record version     2.1.2
Action Pack version       2.1.2
Active Resource version   2.1.2
Action Mailer version     2.1.2
Active Support version    2.1.2
Edge Rails revision       unknown
Application root          /srv/redmine-0.8.3-0/apps/redmine
Environment               development
Database adapter          mysql

Replies (3)

RE: Install errors with Questions plugin - Added by Chad Netzer over 8 years ago

You are using the bitnami stack, and perhaps the rubygems version is too old (not sure why they are still back at 1.0.1). But, here is some info that may help:

http://blog.robustsoftware.co.uk/2009/05/installing-ruby-rails-and-rspec-on.html

RE: Install errors with Questions plugin - Added by Don Caprio over 8 years ago

Yes Chad your are correct. Once I did a non-bitbnami install I was able to install the plugins without a hitch.
Thank you.

RE: Install errors with Questions plugin - Added by Eric Davis over 8 years ago

Run rake db:migrate_plugins from your Redmine directory, not from the plugin directory.

Eric

(1-3/3)