Drop ruby 1.8.6 support

Added by Jean-Baptiste Barth about 7 years ago

When do we drop 1.8.6 support ? I think it's time we start looking toward 1.9.x. Plus I'd really like using Symbol#to_proc ;) Any thought about that ?

Replies (2)

RE: Drop ruby 1.8.6 support - Added by Eric Davis about 7 years ago

When we are on a version of Rails that drops it. If I recall Rails 2.3.x will support 1.8.6 and 3.0.x drops 1.8.6 support.

Eric Davis

RE: Drop ruby 1.8.6 support - Added by Jean-Baptiste Barth about 7 years ago

OK, thanks.

I confirm Rails 3 supports only 1.8.7 and 1.9.2, so we'll see when we switch to Rails 3.

Rails 2.3.x used to support many more rubies: "We recommend Ruby 1.8.7 for use with Rails. Ruby 1.8.6, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not." And 2.3.5+ at least was working with 1.9.1.

(1-2/2)