Revision 8214 breaks Redmine start

Added by Ivan Cenov about 6 years ago

Redmine cannot start after updating trunk to r8214. I experienced this on Redmine test installation.

Ruby 1.8.7,
Rails 2.3.14
Windows XP SP3

trunk r8213 still works.

Here is the log copied from the console:

D:\biz\apps\redmine_trunk>svn update -r 8213
Updating '.':
U    app\models\role.rb
U    app\controllers\roles_controller.rb
U    db\migrate\020_add_role_position.rb
Updated to revision 8213.

D:\biz\apps\redmine_trunk>ruby script\server -e production
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2011-12-15 21:56:40] INFO  WEBrick 1.3.1
[2011-12-15 21:56:40] INFO  ruby 1.8.7 (2010-08-16) [i386-mingw32]
[2011-12-15 21:56:40] INFO  WEBrick::HTTPServer#start: pid=8048 port=3000
[2011-12-15 21:57:01] INFO  going to shutdown ...
[2011-12-15 21:57:01] INFO  WEBrick::HTTPServer#start done.
Exiting

D:\biz\apps\redmine_trunk>svn update -r 8214
Updating '.':
U    test\unit\lib\redmine\menu_manager\menu_item_test.rb
D    vendor\gems\rubytree-0.5.2
U    config\environment.rb
U    lib\redmine\menu_manager.rb
Updated to revision 8214.

D:\biz\apps\redmine_trunk>ruby script\server -e production
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to lo
ad -- tree (MissingSourceFile)
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in
 `require'
        from D:/biz/apps/redmine_trunk/vendor/plugins/redmine_repository/lib/repositories_controller_patch.rb:1
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in
 `require'
        from D:/biz/apps/redmine_trunk/vendor/plugins/redmine_repository/init.rb:3:in `evaluate_init_rb'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:158:in `evaluate_init_rb'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kernel/report
ing.rb:11:in `silence_warnings'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:154:in `evaluate_init_rb'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:48:in `load'
        from D:/biz/apps/redmine_trunk/config/../vendor/plugins/engines/lib/engines/plugin.rb:44:in `load'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:38:in `load_plugins'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `each'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `load_plugins'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:369:in `load_plugins'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:165:in `process'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
        from D:/biz/apps/redmine_trunk/config/environment.rb:24
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in
 `require'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:547:in
 `new_constants_in'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in
 `require'
        from d:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/commands/server.rb:84
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from d:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3

Replies (3)

RE: Revision 8214 breaks Redmine start - Added by Ivan Cenov about 6 years ago

It seems that this problem is related to rubytree deletion.

RE: Revision 8214 breaks Redmine start - Added by Etienne Massip about 6 years ago

It's due to plugin plugins/redmine_repository/lib/repositories_controller_patch.rb which seems to make use of rubytree.

RE: Revision 8214 breaks Redmine start - Added by Ivan Cenov about 6 years ago

Thanks,

After removing the plugin, Redmine, revision HEAD started again.

(1-3/3)