Redmine 2.1.2 won't load plugins routes with ruby 1.9.3p327 on Windows

Added by Martin Dubé almost 5 years ago

Hi,

Just created a bug report which has been assigned and thought other may end up with that same problem.

http://bugs.ruby-lang.org/issues/7374

In short: a bug in File.expand_path is preventing redmine to add plugins routes, resulting in a "no route matches" error.

Solution was to go back to 1.9.3p194

Replies (3)

RE: Redmine 2.1.2 won't load plugins routes with ruby 1.9.3p327 on Windows - Added by M A over 4 years ago

Hi,
I'm new to Redmine and Ruby.
Can you please give pointers on how to "go back to 1.9.3p194"?

Thank you!

RE: Redmine 2.1.2 won't load plugins routes with ruby 1.9.3p327 on Windows - Added by Martin Dubé over 4 years ago

You select the version you want on this page:
http://rubyinstaller.org/downloads/archives

However, I'd suggest to upgrade to p392 release as this bug should be fixed at that point. Latest release are available there:
http://rubyinstaller.org/downloads/

Martin

(1-3/3)